Closed Bug 1350209 Opened 3 years ago Closed 3 years ago

Turn off Android OOP decoding on beta53

Categories

(Firefox for Android :: Audio/Video, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox53 + verified

People

(Reporter: jhlin, Assigned: jhlin)

References

Details

Attachments

(1 file)

Bug 1319987 creates a new version of RemoteDataDecoder that behaves considerably different from the one in beta53. Disable OOP decoding in beta53 so we don't have to worry about bugs that live for only 6 weeks.
Assignee: nobody → jolin
Attachment #8850860 - Flags: review?(snorp)
Attachment #8850860 - Flags: review?(snorp) → review+
Tracking for 53 as this may be causing problems with mp4 playback - in bug 1350279
Please request uplift once this lands (I will check back Sunday night to get ready for Monday's beta 7 build)
No longer blocks: 1350649
Comment on attachment 8850860 [details] [diff] [review]
Turn off remote decoder pref.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1257777
[User impact if declined]: unstable video playback
[Is this code covered by automated tests?]:no
[Has the fix been verified in Nightly?]:no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: low risk
[Why is the change risky/not risky?]: disabling pref makes it behave the exactly same as 52.
[String changes made/needed]:none
Attachment #8850860 - Flags: approval-mozilla-beta?
Comment on attachment 8850860 [details] [diff] [review]
Turn off remote decoder pref.

Per comment #2, disable OOP in Beta53. Beta53+.
Attachment #8850860 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
since this landed on beta, this bug should be marked fixed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Verified as fixed on Beta 53.0b9 (2017-04-04). The media.android-remote-codec.enabled pref is turned off.
Device: Motorola Nexus 6 (Android 7.0)
Status: RESOLVED → VERIFIED
We disabled this for 53. How about 54?
Flags: needinfo?(jolin)
It's enabled in 54.
Flags: needinfo?(jolin)
Blocks: 1257777
You need to log in before you can comment on or make changes to this bug.