Closed Bug 1350404 Opened 3 years ago Closed 2 years ago

Crash in mozilla::layers::CompositorBridgeParent::AllocPWebRenderBridgeParent

Categories

(Core :: Graphics: WebRender, defect, critical)

x86
Windows 10
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 1372880
Tracking Status
firefox55 --- affected

People

(Reporter: marcia, Assigned: aosmond)

References

(Depends on 1 open bug)

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-38f484fd-b747-447d-88cb-56a7c2170324.
=============================================================

Seen while looking at crash stats - crashes started using 20170324030205. Bug 1342450 touched code in this area. ni on kats in case it is related.
Flags: needinfo?(bugmail)
Interesting. These crashes should generally only happen if webrender is enabled. But the crash volume seems kinda high, I would be surprised if that many people have turned on webrender. Still, in the case of the crash of comment 0, we can probably do a better job of logging relevant output so we can diagnose the root cause of webrender failing to start up. I can look into this.
Assignee: nobody → bugmail
Flags: needinfo?(bugmail)
Bug 1352287 could also create the same crash.
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> Bug 1352287 could also create the same crash.

Correction:
 Not same, similar in Crash in mozilla::layers::CompositorBridgeParent::AllocPWebRenderBridgeParent()
Adding mozilla::layers::CrossProcessCompositorBridgeParent::AllocPWebRenderBridgeParent signature to this bug, it has more crashes and will be picked up in Socorro (if it needs its own bug, let me know...)
Crash Signature: [@ mozilla::layers::CompositorBridgeParent::AllocPWebRenderBridgeParent] → [@ mozilla::layers::CompositorBridgeParent::AllocPWebRenderBridgeParent] [@ mozilla::layers::CrossProcessCompositorBridgeParent::AllocPWebRenderBridgeParent]
Assignee: nobody → aosmond
Bughunter has seen this crash on the following urls running with MOZ_WEBRENDER=1:

http://eatsmarter.de/ernaehrung/gesunde-lebensmittel/heidelbeeren-gesund
http://m.sport1.de/
http://m.sport1.de/transfermarkt/2017/06/transfers-thorsten-legat-lehnt-angeblich-angebot-aus-china-ab
http://schoener-fernsehen.com/mobile
http://www.superpride.com.br/
http://www.t-online.de/unterhaltung/tv/id_81338602/-tatort-tod-eines-schwulen-lehrers-in-berlin-neukoelln.html

Unfortunately, I've been unable to reproduce manually. Resubmitting the urls to Bughunter does reproduce somewhat unreliably perhaps due to the presence of other crashes which mask this one.

I also see the following message in the log for both opt and debug builds most of the time though not always.

[Child 13252] ###!!! ABORT: IPDL error [PCompositorBridgeChild]: "constructor for actor failed". abort()ing as a result.: file /home/worker/workspace/build/src/ipc/glue/ProtocolUtils.cpp, line 305
Attached video 2017-06-24_14-50-09.mp4
For me, this is a reliable way to reproduce this crash.

(Darkspirit from bug 1352092 comment 6)
> Crash on https://css-tricks.com/examples/ShapesOfCSS/

Ctrl + click multiple times to open some tabs of it.
Then click on the first tab and repeat pressing Ctrl+W. If I got a tab crash, I clicked on the "close tab" button below the in-tab crash reporter.

After the video ends, I go to about:crashes again and copy this for you:

Meldungs-ID 	Sendedatum
bp-95cbe6c1-86de-459b-941e-8ba4c0170624 24.06.17 14:51 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ]
bp-3870734d-f9b1-40f1-bbf0-3472c0170624 24.06.17 14:51 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ]
bp-3478368c-0b79-4dd3-a5b0-f65570170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
bp-e96169b9-3862-4de5-beb8-af86c0170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
bp-9a4b0ef7-cb48-4356-b878-378ff0170624 24.06.17 14:50 [@ mozilla::layers::CrossProcessCompositorBridgeParent::AllocPWebRenderBridgeParent ]
bp-b253ce14-6653-4ecf-9eca-a33f80170624 24.06.17 14:50 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ]
bp-af7bc2f2-4025-46cf-8472-a2c960170624 24.06.17 14:50 [@ mozilla::layers::CrossProcessCompositorBridgeParent::AllocPWebRenderBridgeParent ]
= this bug!
bp-8ee6474e-0396-42d7-9096-6f93b0170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
bp-9966bae7-e496-4e29-ba44-880740170624 24.06.17 14:50 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ]
bp-e48edef4-7937-45a6-aca4-dc7d00170624 24.06.17 14:50 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ]
= bug 1352092
bp-2f87cff6-87bb-4fd0-bcfd-af9a80170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
bp-5e015558-a556-47ad-9725-08d4a0170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
bp-33aeddc5-25eb-4a0a-9908-893750170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
bp-244e463b-26d7-49a6-905e-dbae40170624 24.06.17 14:50 [@ mozilla::layers::PWebRenderBridgeChild::SendCreate ]
= bug 1350408
(In reply to Darkspirit from comment #8)
Normally, if I open only one tab of that URL, wait a bit and close it then, I only get one [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ] report.

I wanted to test it for you now and give you the report, but this time I got a gpu-process crash.
bp-30f4d097-1d0f-42f9-820f-56e140170624 [@ @0x405b17 ]
See bug 1375058 comment 3: I don't want to have a browser crash on every webrender crash, so I have to use the gpu-process on Linux (even it is not officially supported). A gpu-process crash is "random inside the window" for one second and does not destroy anything and mostly only comes after or between other crashes.

After this, I tried again and opened only one tab of that URL (webrender crash: random inside browser window), waited and closed it, and got only one: bp-e4bcf277-af8b-40b6-a432-0275e0170624 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ] as promised.
May this bug be releated to reinit crashes, see bug 1365009 comment 7 (from Kartikaya Gupta (email:kats@mozilla.com))?
This is the #3 topcrash on Linux in Nightly 20170623100152. Over the past 7 days there have been 18 occurrences across 2 installations.

For this bug and bug 1352092 and bug 1350408 it's possible that all the crashes are coming from one or two users.
This is already addressed by Bug 1372880.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372880
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #8)
> For me, this is a reliable way to reproduce this crash.
> 
> (Darkspirit from bug 1352092 comment 6)
> > Crash on https://css-tricks.com/examples/ShapesOfCSS/

Nightly 57 x64 20170815100349 @ Windows 10
This website is now fine with webrender+webrendest enabled.

Last crash on crash-stats.mozilla.com seen with 20170728100358 (2017-07-28).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.