Closed Bug 1350473 Opened 3 years ago Closed 3 years ago

add BUG_COMPONENT to mobile/* files

Categories

(Firefox for Android :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file, 1 obsolete file)

to help associate files, regressions, etc. with proper bugzilla components it makes it convenient when we have BUG_COMPONENTS set for file patterns in moz.build.
Attached patch add BUG_COMPONENT to mobile/* (obsolete) — Splinter Review
please r- if you feel I am way off.  also if you would prefer the definitions to be in different moz.build files.  There is a lot here, but it isn't too crazy.

here is what it looks like at a top level:
$ ./mach file-info bugzilla-component mobile/android/**
Android Background Services :: Android Sync
  mobile/android/services
Android Background Services :: Geolocation
  mobile/android/stumbler
Core :: Build Config
  mobile/android/Makefile.in
Firefox for Android :: Build Config & IDE Support
  mobile/android/LICENSE
  mobile/android/app
  mobile/android/app.mozbuild
  mobile/android/base
  mobile/android/build
  mobile/android/build.mk
  mobile/android/config
  mobile/android/confvars.sh
  mobile/android/debug_sign_tool.py
  mobile/android/gradle
  mobile/android/gradle.configure
  mobile/android/installer
  mobile/android/mach_commands.py
  mobile/android/mach_commands.pyc
  mobile/android/moz.build
  mobile/android/moz.configure
Firefox for Android :: GeckoView
  mobile/android/geckoview
  mobile/android/geckoview_example
Firefox for Android :: General
  mobile/android/bouncer
  mobile/android/branding
  mobile/android/chrome
  mobile/android/components
  mobile/android/docs
  mobile/android/extensions
  mobile/android/fonts
  mobile/android/javaaddons
  mobile/android/locales
  mobile/android/modules
  mobile/android/thirdparty
Firefox for Android :: Search Activity
  mobile/android/search
Firefox for Android :: Testing
  mobile/android/tests
Firefox for Android :: Theme and Visual Design
  mobile/android/themes

and an example of a subdir:
$ ./mach file-info bugzilla-component mobile/android/app/**
Firefox for Android :: Build Config & IDE Support
  mobile/android/app/build.gradle
  mobile/android/app/checkstyle.xml
  mobile/android/app/findbugs-exclude.xml
  mobile/android/app/moz.build
  mobile/android/app/omnijar
  mobile/android/app/src
  mobile/android/app/ua-update.json.in
Firefox for Android :: General
  mobile/android/app/assets
  mobile/android/app/lint.xml
  mobile/android/app/mobile.ico
  mobile/android/app/mobile.js


you could apply the patch and examine for fun!
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8851163 - Flags: review?(snorp)
Comment on attachment 8851163 [details] [diff] [review]
add BUG_COMPONENT to mobile/*

Review of attachment 8851163 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/moz.build
@@ +29,5 @@
> +    BUG_COMPONENT = ('Firefox for Android', 'General')
> +
> +with Files('java/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'General')
> +

java/org/mozilla/gecko/activitystream** might arguably be classified as "Awesomescreen" as well (but I'm not quite sure).

@@ +38,5 @@
> +    BUG_COMPONENT = ('Firefox for Android', 'Distributions')
> +
> +with Files('java/org/mozilla/gecko/firstrun/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'First Run')
> +

Everything inside java/org/mozilla/gecko/home/** can be classified into "Awesomescreen".

@@ +46,5 @@
> +with Files('java/org/mozilla/gecko/javaaddons/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'GeckoView')
> +
> +with Files('java/org/mozilla/gecko/mdns/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'GeckoView')

Not sure, is MDNS really GeckoView-specific?

@@ +53,5 @@
> +    BUG_COMPONENT = ('Firefox for Android', 'Audio/Video')
> +
> +with Files('java/org/mozilla/gecko/mozglue/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'Audio/Video')
> +

java/org/mozilla/gecko/preferences** is "Settings and Preferences".

@@ +59,5 @@
> +    BUG_COMPONENT = ('Firefox for Android', 'Reader View')
> +
> +with Files('java/org/mozilla/gecko/restrictions/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'Family Friendly Browsing')
> +

java/org/mozilla/gecko/telemetry** is "Metrics".

@@ +62,5 @@
> +    BUG_COMPONENT = ('Firefox for Android', 'Family Friendly Browsing')
> +
> +with Files('java/org/mozilla/gecko/text/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'GeckoView')
> +

java/org/mozilla/gecko/webapps** is "Web Apps".

@@ +94,5 @@
> +with Files('resources/xml*/*preference*'):
> +    BUG_COMPONENT = ('Firefox for Android', 'Settings and Preferences')
> +
> +with Files('resources/menu-*/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'Awesomescreen')

I don't think this is necessarily true for all menus in here. Only files with "home" or "activitystream" in their name definitively belong to the Awesomescreen, and browsersearch_contextmenu.xml as well I think. Everything else is probably "General" or some other component.

::: mobile/android/moz.build
@@ +7,5 @@
> +with Files('**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'Build Config & IDE Support')
> +
> +with Files('bouncer/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'General')

Bouncer could be "Distributions".
Comment on attachment 8851163 [details] [diff] [review]
add BUG_COMPONENT to mobile/*

Review of attachment 8851163 [details] [diff] [review]:
-----------------------------------------------------------------

Jan's comments make sense to me, and you should also add one of these clauses for mobile/geckoview/* (unless I just didn't see it?)

::: mobile/android/base/moz.build
@@ +43,5 @@
> +with Files('java/org/mozilla/gecko/icons/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'Favicon Handling')
> +
> +with Files('java/org/mozilla/gecko/javaaddons/**'):
> +    BUG_COMPONENT = ('Firefox for Android', 'GeckoView')

Only stuff in mobile/android/geckoview should be marked GeckoView, since those are the only files that are actually built with it right now.
Attachment #8851163 - Flags: review?(snorp) → review-
thanks for the great feedback- apologies for the delay in updating and addressing the feedback- I have updated this and accounted for the moving files; Please r- if there are little things to change, I am happy to make this closer to perfect!
Attachment #8851163 - Attachment is obsolete: true
Attachment #8856686 - Flags: review?(snorp)
Attachment #8856686 - Flags: review?(snorp) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4f8853d384a9
add BUG_COMPONENT to mobile/* files. r=snorp
https://hg.mozilla.org/mozilla-central/rev/4f8853d384a9
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.