Absolute position child of flexbox element positioned incorrectly

RESOLVED DUPLICATE of bug 1345873

Status

()

defect
RESOLVED DUPLICATE of bug 1345873
2 years ago
2 years ago

People

(Reporter: marek.raida, Unassigned)

Tracking

({regression})

52 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed, firefox53 fixed, firefox54 fixed, firefox55 fixed)

Details

Attachments

(5 attachments)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170316213829

Steps to reproduce:

Open enclosed document


Actual results:

div.media , which is in flow after absolutely positioned element div.category, is positioned on the right ow window


Expected results:

div.media should be positioned on the left of the window
If you open inspector and disable a re-enable position:absolute on div.category, 
div.media is suddenly positioned on the left, what is expected position, but differs from the initial painting, so should be considered as a bug.
Webkit/Blink based browsers paint it more properly.

Comment 1

2 years ago
Could you attach a screenshot of the rendering on Chrome? (as removing position:absolute doesn't return the rendering to the supposed layout)
Flags: needinfo?(marek.raida)
Reporter

Comment 2

2 years ago
Posted image chrome-rendeing.png
Flags: needinfo?(marek.raida)
Reporter

Comment 3

2 years ago
Posted image safari-rendeing.png
Reporter

Comment 4

2 years ago
Reporter

Comment 5

2 years ago
Reporter

Comment 6

2 years ago
sure, here it comes... is it sufficient?

Comment 7

2 years ago
It looks like a dupe of bug 1345873.
Blocks: 1269045
Component: Untriaged → Layout
Keywords: regression
Product: Firefox → Core
Reporter

Comment 8

2 years ago
yes, it is duplicate
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345873
You need to log in before you can comment on or make changes to this bug.