Closed Bug 135061 Opened 23 years ago Closed 11 years ago

Cache should be sharable by different apps that embed Gecko

Categories

(Core :: Networking: Cache, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: braden, Unassigned)

References

Details

Different apps that embed Gecko should be able to share cache data.

(Spawned from bug 134959.)
Blocks: 135137
As much as this sounds reasonable on first sight I wonder what it really means?
Should the user be able to specify the same cache directory for both apps?
Or should there be a shared default location for all apps from the start?
And then, what if both apps run at the same time? At the moment we dont even
have decent profile sharing protection for two instances of mozilla running
at the same time. And what if the two apps have different prefs for cache size?
Just wondering ...
Apps would share cache preferences.
Priority: -- → P3
Target Milestone: --- → Future
Status: NEW → ASSIGNED
-> me
Assignee: gordon → darin
Status: ASSIGNED → NEW
Priority: P3 → --
Target Milestone: Future → mozilla1.9alpha
Blocks: 252640
Depends on: 217538
*** Bug 250856 has been marked as a duplicate of this bug. ***
Target Milestone: mozilla1.9alpha → Future
Assignee: darin → nobody
QA Contact: tever → networking.cache
Removing the dependency on bug 217538 that made no sense (217538 is a crypto bug).
No longer depends on: 217538
can somebody tell me why this 11 year old bug is still new?
It's pretty clear we're never going to implement this.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Why not?
(In reply to Ben O'Brien from comment #8)
> Why not?

The high priorities for the cache are that it has to be as fast as possible and as crash-resistant as possible. Part of making that possible will undoubtedly be an underlying assumption that no other applications are modifying the cache or reading from it. Further, Gecko doesn't allow apps to share any part of the profile, and the cache relies on Gecko's profile locking stuff. Also, we need the flexibility to change the file format of the cache at any time without notice, and the flexibility to change the APIs for accessing the cache at any time without notice. No stable API and no stable file format means that any apps trying to share the cache would break regularly (potentially every six weeks).

Finally, and perhaps most importantly, Gecko, and Gecko development processes, are  being optimized for Firefox and FirefoxOS, admittedly at the expense of any non-Firefox(OS) apps. So, the priorities underlying this bug are completely opposite of the project-wide priorities for Gecko.
What about having an option to have individual computer profiles. If they are then synced over Firefox sync it will be like each of them are a different computer. After all each of them are different computers. The option would be off by default and if you look up the problem you would find this instead of nothing.

Also this would only effect a small percent of the users. However they are generally the power users who have been instrumental in spreading firefox. I have converted several businesses to using firefox and from there many of the employees. The people who I convince to use firefox will never face this problem. Only computer techies and such face this problem.
You need to log in before you can comment on or make changes to this bug.