Closed Bug 1350974 Opened 3 years ago Closed 3 years ago

Cancelling installer UAC prompt closes installer

Categories

(Firefox :: Installer, defect)

Unspecified
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- verified

People

(Reporter: mhowell, Assigned: mhowell)

References

Details

Attachments

(1 file)

STR:
1) Run a Firefox installer (stub or full, any channel)
2) Cancel the resulting UAC prompt

Expected behavior:
The installer offers a default install path inside the user's home directory, then installation proceeds as normal without ever requiring elevation.

Actual behavior:
The installer exits.
Status: NEW → ASSIGNED
Comment on attachment 8851661 [details]
Bug 1350974 - Continue installing unelevated if the UAC prompt is rejected, and don't prompt a second time in the stub installer.

https://reviewboard.mozilla.org/r/123922/#review126536
Attachment #8851661 - Flags: review?(agashlin) → review+
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ecd628a7910
Continue installing unelevated if the UAC prompt is rejected, and don't prompt a second time in the stub installer. r=agashlin
https://hg.mozilla.org/mozilla-central/rev/0ecd628a7910
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Please confirm the user experience when declining the UAC prompt, does the stub just launch? 
Chrome prompts the user "Google Chrome can be installed without administrative right. Continue?"
Flags: needinfo?(mhowell)
Michael, this is about allowing a fall-back to users who decline the UAC prompt, so that Firefox gets installed into the user's home directory instead of C:\Program Files. Are you OK with just launching the stub when the user declines the UAC?
Now with NI to Michael
Flags: needinfo?(mverdi)
Actually I am told this is a regression, removing the NI to Michael since we'll implement it the following way:
- User dismisses the UAC prompt
- Installer launches and installs to the user's home directory
Flags: needinfo?(mverdi)
Flags: needinfo?(mhowell)
Blocks: 1348127
Duplicate of this bug: 1357494
I have reproduced this Bug on Nightly 55.0a1(2017-03-27) on Windows 10, 64-bit 

The bug's fix is now verified on latest  Nightly 55.0a1 (2017-05-24)

Nightly 55.0a1:
Build ID 	20170524030204
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170524]
Flags: qe-verify+
I've reproduced the initial issue on Windows 7 x64 using Nightly 55.oa1 (2017-03-27).
Verified fixed on Windows 7 x64 and Windows 10 x86 using Firefox 55 Beta 3 (buildID: 20170619071723).
Status: RESOLVED → VERIFIED
Romain: can you verify if this is a regression or valid post Quantum stub installer?
Flags: needinfo?(rtestard)
(In reply to Chris More [:cmore] from comment #14)
> Romain: can you verify if this is a regression or valid post Quantum stub
> installer?

Just tested it's still fixed in Win10 x64  - AFAIK this has been fixed since 55. 
Works as intended:
1 User dismisses the UAC prompt
2 Installer launches and installs to the user's home directory
Flags: needinfo?(rtestard)
You need to log in before you can comment on or make changes to this bug.