Selection for Trash folder on server not saved

RESOLVED FIXED in Thunderbird 59.0

Status

Thunderbird
Account Manager
RESOLVED FIXED
11 months ago
a month ago

People

(Reporter: dano-github, Unassigned)

Tracking

45 Branch
Thunderbird 59.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170317213149

Steps to reproduce:

Go to "Accounts" -> "View settings for account". Click on "Server Settings". Select "Move it to this folder:" radio button under "Server settings", "When I delete a message:" heading. Select "Inbox" -> "Trash". Click OK button.

Stop Thunderbird
Start Thunderbird




Actual results:

Next to "Move it to this folder:" the selection is now "Choose folder". 


Expected results:

The previously selected trash folder should be shown.
(Reporter)

Comment 1

11 months ago
This is consistent across different machines using version 45.8.0. The account is an IMAP account.

Comment 2

11 months ago
Yes, I've noticed on occasions that the selector doesn't show the previous selection. Maybe time to fix this.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 months ago
Apparently the root cause was reported in bug 836631. Time to fix it, no?
See Also: → bug 836631

Updated

10 months ago
Component: Untriaged → Account Manager

Comment 4

10 months ago
Jorg do you have a reproducible test setup where you would try out the patches?

Comment 5

10 months ago
Created attachment 8858290 [details]
Screenshot showing the problem

(In reply to :aceman from comment #4)
> Jorg do you have a reproducible test setup where you would try out the
> patches?
Open the Server Settings of any IMAP account and see that it doesn't show what the Trash folder is.

Comment 6

10 months ago
It's not that easy. On my single IMAP server it shows the Trash folder correctly in the UI.

I think it needs a server where the trash folder isn't called Trash. OR a localized nightly of TB where special trash folder is displayed in the UI with a different name than Trash.

Updated

7 months ago
See Also: → bug 1382740

Updated

7 months ago
See Also: bug 1382740

Updated

7 months ago
Duplicate of this bug: 1382740

Updated

7 months ago
Duplicate of this bug: 1382740

Updated

7 months ago
See Also: → bug 1381217

Comment 9

7 months ago
(In reply to :aceman from comment #6)
> It's not that easy. On my single IMAP server it shows the Trash folder
> correctly in the UI.
Yes, for a while until restart. But at no time does a deleted message go to the selected folder, at least not for me.

Comment 10

7 months ago
Reporter, are you saying that the setting gets forgotten or also that it's never obeyed, neither before nor after forgetting it?
(Reporter)

Comment 11

7 months ago
It is obeyed once it is set until the application is shut down. When I start it again, the setting has been forgotten. The field is set to "Choose Folder".

Updated

6 months ago
Summary: Selection for Trash folder on server not saved by application → Selection for Trash folder on server not saved

Comment 12

a month ago
This should be fixed by the improvements we made in bug 1335982, bug 1428666 and bug 1427507. Try it on a Daily version after today.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 59.0

Comment 13

a month ago
Oh, I forgot to mention: This will only work for non-localised versions of TB. For localised versions and trash folders with non-ASCII characters, see bug 1427940 which will be the last issue to solve here.
You need to log in before you can comment on or make changes to this bug.