Closed Bug 1351511 Opened 2 years ago Closed 2 years ago

Convert nsDisplaySolidColorRegion to WR DisplayItems

Categories

(Core :: Graphics: WebRender, defect, P1)

51 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: mchang, Assigned: cleu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-mvp])

Attachments

(3 files)

No description provided.
See Also: → 1339575
Summary: Convert nsSolidColorRegion to WR DisplayItems → Convert nsDisplaySolidColorRegion to WR DisplayItems
Michael will help on this case.
Assignee: mchang → cleu
Blocks: layers-free
Hi Markus

Do you know what circumstances will utilize this display item?

I want to test its correctness, but got no luck entering this part of code.
Flags: needinfo?(mstange)
It's used for the "modal" find bar UI, which you can enable by flipping the pref findbar.modalHighlight to true. If you then search for a word on a page which occurs multiple times, you can see the whole page except for those word occurences go darker. This darkening is achieved by putting an nsDisplaySolidColorRegion with partially-transparent black on top of the page.
Flags: needinfo?(mstange)
Attachment #8897345 - Flags: review?(mstange)
BTW, I found something strange when I enable modal highlight.

The left side is Firefox Beta, and the right one is nightly, webrender is not enabled on both browser.

I use cmd+F to search "wiki" and "free", the left side will clean old highlights when I change my keyword while right side won't.

I have tried webrender/layers-free on/off but it seems that they are irrelevant.

Is that an expected behavior?
Flags: needinfo?(mstange)
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [wr-mvp]
Target Milestone: --- → mozilla57
That's not expected behavior. Can you still reproduce this? I can't.
Flags: needinfo?(mstange) → needinfo?(cleu)
Comment on attachment 8897345 [details]
Bug 1351511 - Support nsDisplaySolidColorRegion to WR DisplayItems

https://reviewboard.mozilla.org/r/168652/#review182762
Attachment #8897345 - Flags: review?(mstange) → review+
Yes, still reproducible, both "wiki" and "free" are highlighted after I change my cmd+F keyword
Flags: needinfo?(cleu)
Keywords: checkin-needed
(In reply to Michael Leu[:Lenzak](UTC+8) from comment #11)
> Created attachment 8906435 [details]
> Screen Shot 2017-09-11 at 10.19.14 AM.png
> 
> Yes, still reproducible, both "wiki" and "free" are highlighted after I
> change my cmd+F keyword

It also reproducible on Ubuntu, too.
Ah, I couldn't reproduce it because I had the "Highlight All" button checked. Can you please file a new bug for this and make it block bug 1312008? Thanks.
See Also: → 1398717
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/52e22eaebe72
Support nsDisplaySolidColorRegion to WR DisplayItems r=mstange
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/52e22eaebe72
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.