Closed Bug 1351556 Opened 4 years ago Closed 4 years ago

PWA: Collect information on the number of users using PWA standalone mode

Categories

(Firefox for Android Graveyard :: Metrics, defect, P1)

defect

Tracking

(firefox55 fixed)

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: wesley_huang, Assigned: cnevinchen)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → cnevinchen
Attachment #8853828 - Flags: review?(s.kaspari) → review?(dale)
Comment on attachment 8853828 [details]
Bug 1351556 - Collect information on the number of users using PWA.

https://reviewboard.mozilla.org/r/125464/#review128460

I don't think onCreate() is sufficient. We might be re-using an already existing instance and just go through onNewIntent() and load a new webapp without re-creating the activity. I flagged dale as additional reviewer, he can help with finding all entry points.
Attachment #8853828 - Flags: review-
Hi Joe
I thought we just need the count of distinct users. So the count of activity launch should be enough.
Is that correct?
Flags: needinfo?(jcheng)
Comment on attachment 8853828 [details]
Bug 1351556 - Collect information on the number of users using PWA.

As Sebastian said, but will expand a little. If we want to count how many times an app is launched from the homescreen, onCreate will capture most cases, however there are times when running multiple apps that an activity may get reused by seperate apps, so we would need to capture that within http://searchfox.org/mozilla-central/source/mobile/android/base/java/org/mozilla/gecko/webapps/WebAppActivity.java#142
Attachment #8853828 - Flags: review?(dale)
Attachment #8853828 - Flags: review?(dale)
Priority: -- → P1
Comment on attachment 8853828 [details]
Bug 1351556 - Collect information on the number of users using PWA.

That looks great, cheers
Attachment #8853828 - Flags: review?(dale) → review+
Hi Sebastian.
Could you please help me look at this once again before I land this patch?
Thank you!
Flags: needinfo?(s.kaspari)
Look good!
Flags: needinfo?(s.kaspari)
Comment on attachment 8853828 [details]
Bug 1351556 - Collect information on the number of users using PWA.

https://reviewboard.mozilla.org/r/125464/#review129886
Attachment #8853828 - Flags: review?(s.kaspari) → review+
it looks like it's resolved but what i have in mind on what we want to learn initially are 
- Collect information on the number of Firefox launches using PWA standalone mode
- Collect information on the number of progressive web apps that’s added to homescreen
- Collect information on the number of users using PWA
Flags: needinfo?(jcheng)
Pushed by nechen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ac21e09b76bd
Collect information on the number of users using PWA. r=sebastian
Duplicate of this bug: 1351554
https://hg.mozilla.org/mozilla-central/rev/ac21e09b76bd
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Joe, what is our definition of PWA? Web properties having a manifest link?
Flags: needinfo?(jcheng)
What I have in mind regarding these is that we want to know if users are using the standalone mode (e.g. after adding an icon to the homescreen and repeatedly using it as an app) instead of just usage as users come across web properties having a manifest during regular browsing. 

- Collect information on the number of Firefox launches using PWA standalone mode
- Collect information on the number of users using PWA
Flags: needinfo?(jcheng)
changing the summary per comment 16
Summary: PWA: Collect information on the number of users using PWA → PWA: Collect information on the number of users using PWA standalone mode
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.