Word is not bolded in plain text when between asterisks if it ends on a number

RESOLVED DUPLICATE of bug 950605

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 950605
a year ago
a year ago

People

(Reporter: karaluh, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170303012758

Steps to reproduce:

I am using enhanced plain text e-mail formatting in some of my server logs. To distinguish parts of the e-mail I bold some words by enclosing them in asterisks.


Actual results:

The words that end with a number aren't displayed in bold.


Expected results:

All words enclosed in asterisks displayed in bold in enhanced plain text.

Comment 1

a year ago
Yes, I can confirm that, *bold* shows in bold, *bold123* does not.

It looks like this is intentional, we'd have to ask the original author why.

Relevant code:
https://dxr.mozilla.org/comm-central/rev/4c7c05a49f3ce40aa0969beccb397380a8907f4a/mozilla/netwerk/streamconv/converters/mozTXTToHTMLConv.cpp#658
https://dxr.mozilla.org/comm-central/rev/4c7c05a49f3ce40aa0969beccb397380a8907f4a/mozilla/netwerk/streamconv/converters/mozTXTToHTMLConv.cpp#1127

Ben?
Flags: needinfo?(ben.bucksch)

Comment 2

a year ago
Duplicate of Bug 950605

Comment 3

a year ago
(In reply to Jorg K (GMT+1) from comment #1)
> Yes, I can confirm that, *bold* shows in bold, *bold123* does not.
> 
> It looks like this is intentional, we'd have to ask the original author why.

Please refer:
Bug 106028 Comment #22 and
Bug 106028 Comment #63

Comment 4

a year ago
(In reply to Alfred Peters from comment #2)
> Duplicate of Bug 950605

Better:
Duplicate of Bug 949066

Comment 5

a year ago
Bug 949066 has a horrible discussion and was closed as WONTFIX, as per bug 949066 comment #8, bug 950605 was filed for this purpose. Thanks for triaging, Alfred.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(ben.bucksch)
Resolution: --- → DUPLICATE
Duplicate of bug: 950605
You need to log in before you can comment on or make changes to this bug.