Closed Bug 1352115 Opened 2 years ago Closed 2 years ago

CSS_SELECTOR(s) and TOOLBAR_EYEDROPPER are missing in Histograms.json

Categories

(DevTools :: Inspector, enhancement, P3)

enhancement

Tracking

(firefox55 fixed)

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: firefish6000, Assigned: miker)

References

Details

Attachments

(1 file, 1 obsolete file)

devtools/client/shared/telemetry.js references the histograms
DEVTOOLS_COPY_FULL_CSS_SELECTOR_OPENED_COUNT,
DEVTOOLS_COPY_UNIQUE_CSS_SELECTOR_OPENED_COUNT,
DEVTOOLS_TOOLBAR_EYEDROPPER_OPENED_COUNT

however, they are not yet in Histograms.json.
lack of DEVTOOLS_COPY_FULL_CSS_SELECTOR_OPENED_COUNT is also mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=1346310
Assignee: nobody → pbrosset
Priority: -- → P3
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Some explanation about the change I'm about to make:

- DEVTOOLS_TOOLBAR_EYEDROPPER_OPENED_COUNT:
this was part of a group of eyedropper probes that got added/changed a while ago in bug 1262437. There are 4 related probes, and I had just forgotten to add this one. So, I'm going to add it and use the same properties as the other eyedropper probes.

- DEVTOOLS_COPY_FULL_CSS_SELECTOR_OPENED_COUNT, DEVTOOLS_COPY_UNIQUE_CSS_SELECTOR_OPENED_COUNT:
These are 2 new probes that got added in bug 1323700 but not declared in Histograms.json until now.
They will be useful for us to know whether people actually use these features, and if one is more useful than the other so that, perhaps, we can remove one at some stage.
I'll just make these 2 expire in 57, no need to keep gathering the data all the time.
Duplicate of this bug: 1346310
Bryan: does comment 1 sound good to you? At least for the css selector features.
For the eyedropper, I was looking at some of the data and filed bug 1355080 as a result. Might be interested for you to look at.
Flags: needinfo?(clarkbw)
pbro: sounds good to me!
Flags: needinfo?(clarkbw)
Comment on attachment 8856512 [details]
Bug 1352115 - Adding missing probes to Histograms.json;

https://reviewboard.mozilla.org/r/128464/#review131614

data-r=me
Attachment #8856512 - Flags: review?(benjamin) → review+
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65cf36aa783f
Adding missing probes to Histograms.json; r=bsmedberg
backed out for bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=90949702&repo=autoland
Flags: needinfo?(pbrosset)
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d80c517658f5
Backed out changeset 65cf36aa783f for bustage
Depends on: 1356223
I needed to implement this as part of bug 1356223 so I will grab this.
Assignee: pbrosset → mratcliffe
Attachment #8856512 - Attachment is obsolete: true
Comment on attachment 8859565 [details]
Bug 1352115 - Add scalars for toolbareyedropper, copyuniquecssselector and copyfullcssselector

@bsmedberg: It would be awesome if you could let us know if you are happy with the probes I have added to toolkit/components/telemetry/Scalars.yaml.
Attachment #8859565 - Flags: feedback?(benjamin)
Comment on attachment 8859565 [details]
Bug 1352115 - Add scalars for toolbareyedropper, copyuniquecssselector and copyfullcssselector

https://reviewboard.mozilla.org/r/131558/#review134314

data-r=me (I did not review the code)
Attachment #8859565 - Flags: review+
Attachment #8859565 - Flags: feedback?(benjamin)
Comment on attachment 8859565 [details]
Bug 1352115 - Add scalars for toolbareyedropper, copyuniquecssselector and copyfullcssselector

https://reviewboard.mozilla.org/r/131558/#review134778
Attachment #8859565 - Flags: review?(pbrosset) → review+
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ab7f74c36a2
Add scalars for toolbareyedropper, copyuniquecssselector and copyfullcssselector r=bsmedberg,pbro
https://hg.mozilla.org/mozilla-central/rev/7ab7f74c36a2
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Flags: needinfo?(pbrosset)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.