Nightly - "Add <search engine name here>" (from the search bar) doesn't work.

VERIFIED FIXED in Firefox 55

Status

()

VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: liubomirwm, Assigned: aryx)

Tracking

(Depends on: 1 bug, {regression})

55 Branch
Firefox 55
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
When you visit for example Facebook, Wikipedia, YouTube or so, a green + appears in the search bar. When you type something it shows predictions along with the "Add <search engine name here>" button. That button doesn't work on click.
Assignee: nobody → aryx.bugmail
Blocks: 1214284
Severity: minor → normal
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Comment hidden (mozreview-request)
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected

Comment 2

2 years ago
mozreview-review
Comment on attachment 8853158 [details]
Bug 1352161 - Fix search engine installation from searchbar.

https://reviewboard.mozilla.org/r/125226/#review128496

Thanks! And sorry I introduced this mistake while landing the patch from bug 1214284.

I wish this had test coverage, but I'm not requiring it here as writing a test shouldn't block fixing this currently completely broken piece of UI.
Attachment #8853158 - Flags: review?(florian) → review+
Aryx, is there any reason this hasn't landed yet, or was it just missed?
Flags: needinfo?(aryx.bugmail)
Blocks: 1356131

Comment 4

2 years ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/7971ea016601
Fix search engine installation from searchbar. r=florian
Sorry, I wanted to add a testcase before landing, but didn't find time yet, so I landed the patch and opened bug 1356145 for adding the test case.
Flags: needinfo?(aryx.bugmail)
Duplicate of this bug: 1356131

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7971ea016601
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Duplicate of this bug: 1356535

Comment 9

2 years ago
I have reproduced this bug with Firefox Nightly 55.0a1(2017-03-31)in 64 bit Ubuntu 16.04

This bug is now verified as fixed in Latest Nightly 55.0a1

Build ID 	20170414100243
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170412]
Duplicate of this bug: 1356436

Comment 11

2 years ago
[bugday-20170419]

status-ff55 : FIXED & VERIFIED.

The issue is no longer reproducible on Firefox latest Nightly [BuildID : 20170419030223 , 55.0a1(2017-04-19)(32 bit)]. 
Tests were performed under Windows 10 X 64.

Comment 12

a year ago
I am not able to reproduced this bug 

Os: Windows 7 32 bit
Browser : Firefox Nightly 55.0a1

bugday-[20170426]

Comment 13

a year ago
I managed to reproduce this bug using Nightly from 2017-03-30 on Windows 10. Then I tested it on the latest Nightly and Firefox 55.0b13 and the bug is not reproducing anymore. I believe this is fixed.

Comment 14

a year ago
(In reply to Oana Botisan from comment #13)
> I managed to reproduce this bug using Nightly from 2017-03-30 on Windows 10 x64.
> Then I tested it on the latest Nightly and Firefox 55.0b13 and the bug is
> not reproducing anymore. I believe this is fixed.

I also tested this bug on Ubuntu 16.04 LTS x64 and on macOS 10.11 using Firefox 55.0b13 and the bug is not reproducing. I still think that the issues is fixed.
Thanks all for testing. Marking accordingly.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
You need to log in before you can comment on or make changes to this bug.