No Open Bookmarks Menu Option

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Lee Lammert, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

The Open Book Mark file seems to have been removed from the Bookmark menus -
where it it? It is CRITICAL for users to be able to store their bookmarks on a
separate file system for backups and sharing among multiple machines!

Tried to place the entire User Profile on a remote file system, but it was not
allowed in 0.9.7, in *THIS* build, the Profile Manager would not even open!

Reproducible: Always
Steps to Reproduce:
1.Bookmarks
2.Manage Bookmarks
3.NADA, Zilch, Zippo

Actual Results:  Nothing

Expected Results:  Open a Bookmark file in a remote directory.

This featue has been in NN since 4.x, .. why has it been removed??
blocker ? never..

There is an "import function" in the bookmarks...
Severity: blocker → normal
(Reporter)

Comment 2

16 years ago
Nope. 'Import' is NOT the same as 'Open File'.
(Reporter)

Comment 3

16 years ago
Blocker - CERTAINLY! If the user cannot open his/her Bookmark File, the browser 
cannot be used effectively!

Comment 4

16 years ago
Dupe of bug 17048?
(Reporter)

Comment 5

16 years ago
Nope. Bug 17048 pertains to Roaming, .. this bug pertains to a function that was
present in NN, but has been REMOVED from Mozilla.

Comment 6

16 years ago
Ehh, Roaming is available in Netscape 4.x too, and it does what you want.
(Reporter)

Comment 7

16 years ago
Err, if it's supposed to be there, where is it??

According to bug 17048 and v0.9.9 there *IS* no roaming?? Neither is there any
Roaming with the standard install of NN 4.7?

It is impossible to create a Profile on a remote file system (although you can
select a remote folder, the 'Finish' button does not work WITH a remote folder)??

There is no info in the Mozilla help on Roaming??

Comment 8

16 years ago
Roaming is not implented on Mozilla yet, which is exactly why that bug has been
filed...
(Reporter)

Comment 9

16 years ago
Well, I guess we're back to the original question - 
    What happened to the Open Bookmark File command in the Boomkar Menu??????

Loosing it is certainly a show-stopper, without bookmarks, how are users
supposed to use Mozilla???

Comment 10

16 years ago
First of all, please use a milder tone. Most of us do this in our spare time,
and don't appreciate being yelled at.

The menus in mozilla has been reworked. While in Manage Bookmarks you can use
Tools->Import... to import an already existing bookmark file. I don't know what
else you want, and you have not described it well in this bugreport.
(Reporter)

Comment 11

16 years ago
Sorry if the frustration is showing, but I'm totally clueless as to why a
Bookmark File is souch a misunderstood subject. Believe me, ALL of the volunteer
efforts certainly ARE appreciated, I apologize if it seemed I was indicating
anyhing else.

The original question was:

What happened to the 'Open Bookmark File' option in the File menu of Bookmarks?

Import Bookmarks has nothing to opening and using a bookmark file. For years,
our users have been pointed at a single bookmark file, which is selected using
'Open Bookmark File' in the Bookmark File Menu. This has been removed, for some
reason, from Mozilla.

It was such a simple, yet powerful operation that I find it quite amazing that
nogody seems to know anything about it! Do no Mozilla users have multiple machines?

A Bookmark file is not roaming, .. has nothing to do with importing, .. but the
eimple fact of choosing your own bookmark file, in any folder on the network,
made a lot of users very our happy (including myself).

Does this make any more sense? I would LOVE to use and support Mozilla, but,
right now, it is quite impossible without some way of managing bookmarks within
the browser.

BTW - Is it a known bug where characters entered in a text box appear about one
character per second,. no matter what the typing speed?

Thanks for the reply,

Comment 12

16 years ago
Ok, now i finally see what you mean. I wasn't aware of the fact that mozilla
should after opening the file also *use* it as bookmark file from there on.

Can someone comment on why this menu option was removed?

Comment 13

16 years ago
Why not just use File | Open File?
(Reporter)

Comment 14

16 years ago
| Why not just use File | Open File?

Duh, .. maybe because there **IS** no File | Open File in the Bookmarks Window?

Note: I even downloaded 1.0 just to make sure somebody had fixed the bug before 
it WAS a bug!!

What is it going to take to get this bug addressed?
(Reporter)

Updated

16 years ago
Severity: normal → blocker

Comment 15

16 years ago
How about Mozilla Navigator Window | File | Open File? Won't that work?
(Reporter)

Comment 16

16 years ago
|How about Mozilla Navigator Window | File | Open File? Won't that work?

Guess I don't understand why you would?? There is no way to opening an HTML file 
in the browser window and have that file set as your bookmark file??

????????
(Reporter)

Updated

16 years ago
Summary: No Open Bookmarks Menu Option → No Open Bookmarks File Menu Option

Comment 17

16 years ago
By viewing the HTML file in the browser, you would have access to all the links.

You want to set a profile's bookmarks file to be on a remote drive. Why not just
create a new profile on that remote drive. Then, you can use Import to bring in
whatever bookmarks from whatever file into your new profile.

Comment 18

16 years ago
Marking NEW since I cannot find a duplicate. Adding 4xp keyword, and lowering
the severity to Normal.
Severity: blocker → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
OS: Windows 98 → All
(Reporter)

Comment 19

16 years ago
| By viewing the HTML file in the browser, you would have access to all the 
| links.

What good is accessing the links if Mozilla does not seem them as bookmarks??

! You want to set a profile's bookmarks file to be on a remote drive. Why not 
| just create a new profile on that remote drive.

Probably because it is impossible to create a profile on a drive that is not 
local!! Sure you can select it, but you cannot save a non-local drive as a 
profile folder.

Comment 20

16 years ago
> What good is accessing the links if Mozilla does not seem them as bookmarks??

If you pull up the bookmarks.html file in the browser, you can see the text 
that the bookmarks contain and click on the links. Pretty much the same things 
you can do with the bookmarks menu, except for modifying them.

Back on topic, I think there are actually 2 problems that Lee is having.

First is obviously the lack of the Open Bookmarks menu item. The problem here 
is that he cannot *choose* which file is used to store his bookmarks -- he is 
stuck with the default file within the profile directory.

> If the user cannot open his/her Bookmark File, the browser 
> cannot be used effectively!

The user can easily *open* any bookmark file, using the import feature. The 
problem is that you cannot specify where to save the bookmarks, nor the default 
location to read them from. After digging around in the ASCII of various 
binaries, I discovered that you *can* set the bookmark file location by adding 
this to prefs.js in your profile: 

user_pref("browser.bookmarks.file", "/path/to/bookmarks.html");

It should be *very* easy to add a GUI element to define this and restore the 
Open Bookmarks menu item.

The 2nd problem is that Lee can't create a profile on a "remote" drive:

> it is impossible to create a profile on a drive that is not 
> local!! Sure you can select it, but you cannot save a non-local 
> drive as a profile folder.

Lee, what do you mean by "remote" here? On what OS? Do you mean an NFS-mounted 
drive on a Linux box, or a mapped drive on Windows? If Linux/NFS, have you 
tried using a soft link:

$ ln -s /remote/dir/bookmarks.html ~/.mozilla/user/sfhrg.slt/bookmarks.html

Or are you expecting to be able to specify a URL to use as your bookmark file? 
If so, what types of URLs were/should be allowed? If HTTP, how did the browser 
write them back to the server (GET, POST, PUT)?
(Reporter)

Comment 21

16 years ago
| First is obviously the lack of the Open Bookmarks menu item. The problem here 
| is that he cannot *choose* which file is used to store his bookmarks -- he is 
| stuck with the default file within the profile directory.

Close, but not quite. Opening a 'Bookmark File' implies the browser will USE 
that bookmark file for updates, etc. You cannot open a 'Bookmark' file from a 
normal html page.

| The user can easily *open* any bookmark file, using the import feature. 

False. The user can 'Import' bookmarks from many files types, but you cannot 
*open* (open implies use) with Import.

| I discovered that you *can* set the bookmark file location by adding 
| this to prefs.js in your profile: 
|
| user_pref("browser.bookmarks.file", "/path/to/bookmarks.html");

Does not work in Windoze. Mozilla will not use a file on a remote filesystem - 
i.e. if you choose a remote location for a profile, you cannot 'Finish'. Sure, 
the File Open window let's you pick a remote folder, but you cannot use it. If 
you stick a path directly in userprefs, it creates a new default profile on 
startup.

Also, Windoze, at least, will not support shortcuts/links.

Comment 22

16 years ago
| The problem here is that he cannot *choose* which file is used 
| to store his bookmarks -- he is stuck with the default file within
| the profile directory.

> Close, but not quite. Opening a 'Bookmark File' implies the browser 
> will USE that bookmark file for updates, etc. You cannot open a 
> 'Bookmark' file from a normal html page.

I don't see what I missed. I said 'store', you said 'update' -- same thing. I 
never said that you could use any file.

| The user can easily *open* any bookmark file, using the import feature. 

> False. The user can 'Import' bookmarks from many files types, but 
> you cannot *open* (open implies use) with Import.

Reading *is* a use. But as I said, there's no way to do what you want, except 
possibly the prefs.js file.

| user_pref("browser.bookmarks.file", "/path/to/bookmarks.html");

> Does not work in Windoze.

What type of failure? For what input values?

> Mozilla will not use a file on a remote filesystem - i.e. if you 
> choose a remote location for a profile, you cannot 'Finish'.

You still haven't explained what you mean by "remote". URL? Mapped drive?
UNC (\\Server\Path)?
(Reporter)

Comment 23

16 years ago
> Close, but not quite. Opening a 'Bookmark File' implies the browser 
> will USE that bookmark file for updates, etc. You cannot open a 
> 'Bookmark' file from a normal html page.

| I don't see what I missed. I said 'store', you said 'update' -- same thing. I 
| never said that you could use any file.

Nope. How can you *either* store *or* update a page opened as a normal web 
page?? Are you saying the user should edit the page? I don't think so.

> False. The user can 'Import' bookmarks from many files types, but 
> you cannot *open* (open implies use) with Import.

| Reading *is* a use. But as I said, there's no way to do what you want, except 
| possibly the prefs.js file.

Nope again. Using a Boomark file requiers that the user be able to store new 
bookmarks *IN* the file, reorder, and delete current bookmarks. All 
functionalities present in NN 4.x.

| user_pref("browser.bookmarks.file", "/path/to/bookmarks.html");

> Does not work in Windoze.

| What type of failure? For what input values?

Mozilla will not use any non-local drive as a destination.

| You still haven't explained what you mean by "remote". URL? Mapped drive?
| UNC (\\Server\Path)?

Guess I'm not being simple enough - a 'remote' drive is a drive on a 'remote' 
machine; if a drive is on a machine, it must be accessible via file sharing 
(i.e. UNC name). There are no other options for a Windoze environment. Since 
Mozilla used the 32-bit file open dialog, I saw no reason to try the test by 
mapping a drive. If it *did* work with a mapped drive letter, I would consider 
that an even *bigger* bug <g>!

Comment 24

16 years ago
Sigh, I've had this discussion before and long ago. There is a bug somewhere, if
it wasn't found earlier it may very well have been closed as wontfix or futured
or something.

First of all, this feature wasn't 'removed' from Mozilla. Mozilla and N4.x are
different products and this product just never had that feature. Most people
didn't notice because people who wanted to use this sort of functionality used
Roaming Access(generalizing), which obviously isn't a part of the current
incarnation of Mozilla.

Anyway, more to the point. IIRC that pref is there (thanks craig for finding it
again) and should work. Try it out and report back. I also know there is some
case where it doesn't work(just can't remember which) and that was the point of
the previous bug.

I'd like to refocus this bug with a goal of driving it toward some resolution.
Before we do that we need to know: does setting this pref work with a local
directory and/or a remote directory.

Depending on the answer we can then make this bug be the bug to: simply add the
GUI, or create the feature, or fix the feature(such that remotes work for instance).

Comment 25

16 years ago
| I don't see what I missed. I said 'store', you said 'update' -- same thing. I 
| never said that you could use any file.

> Nope. How can you *either* store *or* update a page opened as a normal web 
> page?? Are you saying the user should edit the page? I don't think so.

Perhaps you aren't aware that bookmarks.html is actually an HTML page that you 
can browse? When Netscape closes, it saves the changes that the user made to 
their bookmarks in a special HTML format, so it can also be read into the 
bookmarks menu. Mozilla saves the changes immediately. So you can browse to 
that page no matter what. If you want to automatically 'save', 'store', 
or 'update' (all different words for the same thing) changes you made to your 
bookmarks, you need to set the prefs (assuming that is working) as I suggested 
to make that file your 'current' bookmarks file.

| Reading *is* a use. 

> Nope again.

Your terminology is very difficult to deal with. How can I read a file without 
using that file?

> Guess I'm not being simple enough 

You're not being detailed enough.

> If it *did* work with a mapped drive letter, I would consider
> that an even *bigger* bug 

Please try it anyway. It works for me in Netscape 4.79 on Windows. (I don't 
have Mozilla on Windows anywhere.) We need to narrow down what exactly works 
and what doesn't to find where the bug is within the code. If it works except 
for using UNCs (and except for the missing dialog to set it) then that's very 
different than not accepting anything at all.

Comment 26

16 years ago
so the quick way to catch up on the Mozilla history of this feature is to do a
bugzilla search on bugs containg "browser.bookmarks.file"

Some quick reading will tell you that this issue was addressed in the release
notes for mozilla  0.9.4 which also notes that one should not allow both NN4.x
and  Seamonkey to point to the same BM file as bad things will happen.

Furthermore, this bug is likely a dupe of bug 104184. 
(Reporter)

Comment 27

16 years ago
| Furthermore, this bug is likely a dupe of bug 104184.

Turns out there are even more related to roaming: 17917, 17048, 124026, 124029, 
.. but I was originally trying to keep it simple with just the Bookmark file.

Looks like Ben/Benoex has accepted the work for a Bookmark UI - since it does 
not appear that the file/open is anything near the simple fix it appeared, we 
might defer to the resolution on: 124029.

Comment 28

16 years ago
| Furthermore, this bug is likely a dupe of bug 104184.

Yes, except for the additional fact that Lee is reporting that it won't 
work with a file specified by UNC name.

> Looks like Ben/Benoex has accepted the work for a Bookmark UI - since 
> it does not appear that the file/open is anything near the simple fix 
> it appeared, we might defer to the resolution on: 124029.

But that talks about roaming, i.e. accessing the file via a URL. It would 
be good to have the ability to specify a "local" bookmark file as well,
for those who want to locate their bookmark file somewhere else on the 
system. (My definition of "local" here means loaded by the OS -- be it 
truly local or something else that the OS can load for us, like a UNC.)
(Reporter)

Comment 29

16 years ago
It has been some time since this bug was deferred to 124029, however it now
appears that bug 124029 is not going to be fixed anywhere anytime soon - the
issues for roaming profiles *may* be too complex.

Is there ANY chance of getting THIS bug resolved (i.e. allowing a separate filet
to be used for bookmarks)? This is NOT the same as bug 124029.

A separate bookmark file would be VERY useful to anyone with multiple machines,
.. and I, for one, have been prevented from using Mozilla until this issue is
resolved.

   Lee

Updated

15 years ago
Attachment #124829 - Flags: superreview?(jaggernaut)
Attachment #124829 - Flags: review?(varga)

Comment 31

15 years ago
Comment on attachment 124829 [details] [diff] [review]
Proposed patch

>+  fp.init(window, "Open Bookmarks File", nsIFilePicker.modeOpen);

This should be localizable.

>+    BMSVC.QueryInterface(Components.interfaces.nsIRDFDataSource);

I think this is unnecessary, let me know if it doesn't work w/o that.

>+    BMSVC.beginUpdateBatch();

This is unnecesary too, since we call it internally when parsing bookmarks.

>+    BMSVC.QueryInterface(Components.interfaces.nsIObserver);
>+    BMSVC.observe(BMSVC, "profile-before-change", "");
>+    PREF.setCharPref("browser.bookmarks.file", fp.file.path);
>+    BMSVC.observe(BMSVC, "profile-after-change", "");
>+    BMSVC.endUpdateBatch();

I don't like this approach, it would be better to add a new method to
nsIBookmarksService or use an RDF command to do it for you in background.
For example, import bookmarks uses an RDF command.

We also need a UI for removing this pref, "Use standard bookmarks file" or
something like that.
Attachment #124829 - Flags: superreview?(jaggernaut)
Attachment #124829 - Flags: review?(varga)
Attachment #124829 - Flags: review-

Comment 32

15 years ago
>>+  fp.init(window, "Open Bookmarks File", nsIFilePicker.modeOpen);
>This should be localizable.
Doh :-[

>>+    BMSVC.QueryInterface(Components.interfaces.nsIRDFDataSource);
>I think this is unnecessary, let me know if it doesn't work w/o that.
Right, I only needed it to call beginUpdateBatch and endUpdateBatch

>>+    BMSVC.beginUpdateBatch();
>This is unnecesary too, since we call it internally when parsing bookmarks.
I didn't want anything nasty to happen between the flush and reload,
but it seems to work without, so consider it gone.

>>+    BMSVC.QueryInterface(Components.interfaces.nsIObserver);
>>+    BMSVC.observe(BMSVC, "profile-before-change", "");
>>+    PREF.setCharPref("browser.bookmarks.file", fp.file.path);
>>+    BMSVC.observe(BMSVC, "profile-after-change", "");
>>+    BMSVC.endUpdateBatch();
>I don't like this approach, it would be better to add a new method to
>nsIBookmarksService or use an RDF command to do it for you in background.
>For example, import bookmarks uses an RDF command.
OK, I'll see about using a command, but I would prefer a new method :-)

>We also need a UI for removing this pref, "Use standard bookmarks file" or
>something like that.
What if it's since been deleted? Perhaps bookmarks should use relative files
instead? Also it's not 4xp :-P

Comment 33

15 years ago
>>We also need a UI for removing this pref, "Use standard bookmarks file" or
>>something like that.
>What if it's since been deleted? Perhaps bookmarks should use relative files
>instead? Also it's not 4xp :-P

Well, if it's since been deleted, a new one will be created.
Perhaps the default bookmarks file should be copied.
However, this is not so important, I just thought it would be nice.

Comment 34

15 years ago
Created attachment 126742 [details] [diff] [review]
Observe the preference

OK, so the new idea is to watch the preference. Unfortunately Flush() reads the
preference, so I had to cache the nsILocalFile instead of mBookmarksAvailable.
Attachment #124829 - Attachment is obsolete: true

Updated

15 years ago
Attachment #126742 - Flags: review?(varga)

Comment 35

15 years ago
Comment on attachment 126742 [details] [diff] [review]
Observe the preference

r=varga with some fixes I mentioned on irc
Attachment #126742 - Flags: review?(varga) → review+

Comment 36

15 years ago
Created attachment 131898 [details] [diff] [review]
Fixes as promised
Attachment #126742 - Attachment is obsolete: true

Updated

15 years ago
Attachment #131898 - Flags: review+

Comment 37

15 years ago
Comment on attachment 131898 [details] [diff] [review]
Fixes as promised

On the basis that no news is good news ;-)
Attachment #131898 - Flags: superreview?(alecf)

Comment 38

15 years ago
Comment on attachment 131898 [details] [diff] [review]
Fixes as promised

nice cleanup... sr=alecf assuming that lazy bookmarks loading still works
Attachment #131898 - Flags: superreview?(alecf) → superreview+

Comment 39

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 40

15 years ago
Err, this is supposed to be in the File menu, not tasks. filed bug 223148
Blocks: 223148
Status: RESOLVED → VERIFIED
Summary: No Open Bookmarks File Menu Option → No Open Bookmarks Menu Option
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.