Closed Bug 1352991 Opened 3 years ago Closed 3 years ago

Pages loaded in Nightly show in the web app

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P1)

55 Branch
ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox55 --- unaffected

People

(Reporter: oana.horvath, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files, 1 obsolete file)

Attached image Screenshot_20170403-152210.png (obsolete) —
Device: Motorola Nexus 6 (Android 7.0)
Build: Nightly 55.0a1 (2017-04-03);

Steps to reproduce:
1. Have a web app (e.g. twitter) and Nightly opened.
2. Go to Nightly and load a page (e.g. google.com).
3. After the page is loaded, return to the web app.

Expected result:


Actual result:
The small URL added to the web app shows the address of the page loaded in Nightly, with the Twitter contents under (see screenshot).

*Furthermore: If you swipe to close Nigthly while the page is still loading, the page will load in the web app, taking over the content and history. If you press the back button it navigates trough the browser's history from that particular tab which was closed.
Blocks: 1285858
Depends on: 1352997
Short-term solution for here (https://dxr.mozilla.org/mozilla-central/rev/38894655c89e68bcd8f45d31a0d3005f2c2b53db/mobile/android/base/java/org/mozilla/gecko/webapps/WebAppActivity.java#101):
- Possibly exit early if the selected tab != TabType.WEBAPP (depending on how much we care if through some other bug a non-web app tab ends up in the WebAppActivity).
- In any case also handle TabEvents.SELECTED - the above suggestion doesn't help when the user is browsing in another web app and then switches between WebAppActivities, or if the web app somehow updates its state while in background.

Medium term, if bug 1352997 works out as expected, each activity should have a better picture of which tab it should have opened, so that could potentially be used for filtering events as well.
Attachment #8853955 - Attachment is obsolete: true
I was able to reproduce this too while testing Custom Tabs.
Blocks: 1337236
Priority: -- → P1
Note to whoever wants to work on this: Something like my short-term solution described in comment 1 will probably be included in bug 1351739 for both custom tabs and web apps. There's still room for further improvements, though, e.g. making use of bug 1352997, or maybe somebody has an even better idea.
similar to bug 1347611. probably a dup.
Now this (and the next screenshot) appears when launching the web app, while Nightly is opened in the background.
So this is neither bug 1358805 nor bug 1347611.
Is this still reproducible given bug 1351739just landed?
Oana,, could you verify?
Flags: needinfo?(oana.horvath)
Verified on Nightly 2017-05-03 and this bug doesn't reproduce, just a short/longer flash of the previous content(bug 1347611).
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(oana.horvath)
Resolution: --- → WORKSFORME
Sorry, marking firefox-55 as unaffected since this was fixed by other bugs.
You need to log in before you can comment on or make changes to this bug.