GIFs are black after watching ~7 different ones

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: alexandermueller1986, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Android 4.4.2; Mobile; rv:52.0) Gecko/52.0 Firefox/52.0
Build ID: 20170324081508

Steps to reproduce:

Go to reddit. Tap on all gifs. After watching about 7 gifs there seems to be a problem with the cache.. any further gifs are displayed black.
Restarting Firefox solves the problem (until you watch another ~7 gifs)


Actual results:

Gifs are displayed black


Expected results:

Gifs show normally

Comment 1

2 years ago
Are those real GIFs, or videos masquerading as such? I.e. if you long press on them while they are playing, does the context menu talk about images or about videos?

Comment 2

2 years ago
Since when have you observed this problem, i.e. did it start after a certain Firefox update?

If those are real GIFs, does the problem also persist if you momentarily switch to the home screen to send Firefox into the background and then back again to Firefox and if necessarily zoom in and out a little to force a repaint?

Also, have you ever seen these symptoms (image appearing as black rectangles) for normal images as well, or only ever for animations?

If yes, this might well be a duplicate of bug 1306971, which we've had trouble tracking down - so if you can reliably reproduce this, it might prove very helpful.
Flags: needinfo?(alexandermueller1986)
(Reporter)

Comment 3

2 years ago
So I just tapped on every video in https://www.reddit.com/r/gifs/ and the fourth turned black. They are all mp4. Every other vid I tap on also turns black. Going to home screen and going back to ff does not help, every video that was still open displays black only, every new one I tap on is black. Reloading the page shows me stills of the videos with a video button on top, but if I tap nothing happens.
With 9gag they are mostly real gifs, and once going to the home screen helped. Also sometimes some vids turn black and others dont (dont know if it was due to gif/mp3).
No, never happens for static images, only gifs/videos. Never had probs for youtube or vimeo either.
The only way to reliably use ff is to force quit it and restart.
Dont know when it started exactly, feels like 2-3 weeks.

So what do I do?

By the way using this bugzilla is a real pain on mobile :-)
Flags: needinfo?(alexandermueller1986)
(Reporter)

Comment 4

2 years ago
Anything else you need? I hope this gets fixed soon, it's a pain to browse the web with this bug. I bet I am not the only one experiencing it, but other ppl don't report it.

Comment 5

2 years ago
Well, one problem is that this is probably device-specific - on my phone I eventually get what I think was an OOM-crash, but no black videos - incidentally, what device are you using?

In any case, if you can reliably reproduce this, then trying a mozregression run (http://mozilla.github.io/mozregression/documentation/usage.html, with "--app fennec") could be helpful if you can pinpoint a specific revision where this problem started.

Black images (as opposed to videos) could be bug 1306971.
Component: General → Audio/Video
(Reporter)

Comment 6

a year ago
This got fixed through update of Firefox. Not sure exactly when it started working again, but I am on 53.0.2 now and everything works as it should.

Couldn't find iut how to mark as fixed (not invalid etc.)


Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.