Closed Bug 1353082 Opened 3 years ago Closed 3 years ago

Don't prefetch URLs with a query string

Categories

(Core :: Networking, defect)

52 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: u408661, Assigned: u408661)

References

Details

(Keywords: site-compat, Whiteboard: [necko-active])

Attachments

(1 file)

This bug is to track the patch to land as part of the bug I cloned (see bug 1349921 comment 36).

+++ This bug was initially created as a clone of Bug #1349921 +++

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

1. Serve attached files on web server (cache headers needed for frame.html)
2. Use proxy to track network calls (dev tools shows that everything works well)
3. Open index.html via web server URL
4. Refresh couple times, back-forward navigation forces bug appearing
5. Track network calls until you will notice unnecessary calls from the past.



Actual results:

Not needed network calls are made. This means that browser somewhy executes stored in cache scripts.



Expected results:

Only defined actions and network calls should be made.

Network sessions attached.
Patrick, FYI, looks like mozreview ignored the fact that this is the same diff, all 'cause I changed the bug number. Sorry :/
Comment on attachment 8854074 [details]
Bug 1353082 - don't prefetch is there's a query string

https://reviewboard.mozilla.org/r/126054/#review128700
Attachment #8854074 - Flags: review?(mcmanus) → review+
Pushed by hurley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/63005e2a6086
don't prefetch is there's a query string r=mcmanus
https://hg.mozilla.org/mozilla-central/rev/63005e2a6086
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Depends on: 1388158
You need to log in before you can comment on or make changes to this bug.