view page info crashes when opened from context menu in sidebar

RESOLVED WORKSFORME

Status

()

Firefox
Page Info Window
RESOLVED WORKSFORME
a year ago
10 months ago

People

(Reporter: mixedpuppy, Unassigned)

Tracking

({crash})

49 Branch
Unspecified
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox54 unaffected, firefox55+ fixed, firefox56+ fixed)

Details

(Whiteboard: triaged)

(Reporter)

Description

a year ago
With patches from bug 1299371 and bug 1353073, view page-info in the sidebar crashes nightly.

STR
- apply patches mentioned
- load an addon with a sidebar
- open context menu
- select view page info

Window opens and Firefox crashes a couple seconds later.
Could not reproduce this when testing the patch from bug 1353073. The page info dialog was properly displayed and Firefox was stable. I've applied the patches on top of the current m-c tip.
(Reporter)

Updated

a year ago
Assignee: nobody → mixedpuppy

Comment 2

a year ago
shane just checking, but believe resolved by later patch
Flags: needinfo?(mixedpuppy)
Whiteboard: triaged
(Reporter)

Comment 3

a year ago
I was able to reproduce again on OSX 10.11.6 with a fresh pull/build from last night.  This actually doesn't require patches from the context fixes and does not require setting remote=true for extensions.  Simply run, load a sidebar, open the context menu on the sidebar, view page info.
No longer depends on: 1299371, 1353073
Flags: needinfo?(mixedpuppy)
Summary: view page info crashes with webextension.remote=true → view page info crashes when opened from context menu in sidebar
(Reporter)

Comment 4

a year ago
Another note, this also does not need an extension to reproduce.  You can use the bookmark sidebar and accomplish the same thing.  The bookmark and extension sidebars are structurally very similar.

- bookmark a page, place it in the bookmarks toolbar
- edit properties, check open in sidebar
- open bookmark (sidebar will appear)
- open context menu in sidebar
- select view page info

page info hangs then crashes in about 20 seconds.
(Reporter)

Updated

a year ago
Keywords: crash
(Reporter)

Updated

a year ago
status-firefox54: --- → unaffected
status-firefox55: --- → affected
tracking-firefox55: --- → ?
OS: Unspecified → Mac OS X
Tracking 55+ for this reproducible crash.
tracking-firefox55: ? → +
(Reporter)

Updated

a year ago
Component: WebExtensions: Untriaged → Page Info Window
Product: Toolkit → Firefox
(Reporter)

Updated

a year ago
Assignee: mixedpuppy → nobody
Florian, can you help find an owner for this issue?
status-firefox56: --- → ?
tracking-firefox56: --- → +
Flags: needinfo?(florian)
Andrei, can your team try and reproduce this and link to the crash report/signature? Thanks.
Flags: needinfo?(andrei.vaida)
(In reply to Shane Caraveo (:mixedpuppy) from comment #4)
> Another note, this also does not need an extension to reproduce.  You can
> use the bookmark sidebar and accomplish the same thing.  The bookmark and
> extension sidebars are structurally very similar.
> 
> - bookmark a page, place it in the bookmarks toolbar
> - edit properties, check open in sidebar
> - open bookmark (sidebar will appear)
> - open context menu in sidebar
> - select view page info
> 
> page info hangs then crashes in about 20 seconds.

I can't reproduce with these steps, does it need to be a specific page? I tried with https://developer.mozilla.org/en-US/
Flags: needinfo?(florian) → needinfo?(mixedpuppy)
I was also unable to reproduce this issue using latest Nightly 56.0a1 and Firefox 55 beta 5 on Mac OS X 10.11.
Flags: needinfo?(andrei.vaida)
(Reporter)

Comment 10

10 months ago
I am also unable to reproduce on nightly now, closing.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(mixedpuppy)
Resolution: --- → WORKSFORME
status-firefox55: affected → fixed
status-firefox56: ? → fixed
You need to log in before you can comment on or make changes to this bug.