Streamlined stub installer for funnelcake 111/112/113

RESOLVED FIXED

Status

()

Firefox
Installer
RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: agashlin, Assigned: agashlin)

Tracking

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fce-active])

Attachments

(8 attachments, 1 obsolete attachment)

(Assignee)

Description

10 months ago
This is an update to the streamlined stub installer for funnelcakes in bug 1328445.

There should be no visible change from that previous version besides a fix for bug 1350405.

This is *not* intended to be landed in this form, it will be tested from builds on Oak and eventually land on a release branch (see bug 1350405 comment 5 and 6).
(Assignee)

Comment 1

10 months ago
Created attachment 8854972 [details] [diff] [review]
Part -1 - back out stub changes from central to beta
Attachment #8854972 - Flags: review?(mhowell)
(Assignee)

Comment 2

10 months ago
Created attachment 8854973 [details] [diff] [review]
Part 0 - Configure for release branding and enable stub installer
Attachment #8854973 - Flags: review?(mhowell)
(Assignee)

Comment 3

10 months ago
Created attachment 8854975 [details] [diff] [review]
Part 1 - Images for streamlined stub installer
Attachment #8854975 - Flags: review?(mhowell)
(Assignee)

Comment 4

10 months ago
Created attachment 8854993 [details] [diff] [review]
Part 2 - Streamlined stub installer

As discussed above, this is intended to be equivalent to the streamlined installer for funnelcake 99/100, but it will not set Firefox as the default browser.

I made one additional change: I took a part of the fix from bug 1350974 to not attempt to install the maintenance service if the user is not an admin. The rest of that fix (handling an admin user who refuses to elevate) involves changes to the installer that aren't in 53 and thus do not apply.
Attachment #8854993 - Flags: review?(mhowell)
(Assignee)

Updated

10 months ago
Depends on: 1350405

Updated

10 months ago
Attachment #8854972 - Flags: review?(mhowell) → review+

Updated

10 months ago
Attachment #8854973 - Flags: review?(mhowell) → review+

Updated

10 months ago
Attachment #8854975 - Flags: review?(mhowell) → review+

Updated

10 months ago
Attachment #8854993 - Flags: review?(mhowell) → review+
(Assignee)

Comment 7

10 months ago
Here is the newly built stub for testing:
https://archive.mozilla.org/pub/firefox/tinderbox-builds/oak-win32/1491510033/firefox-55.0a1.en-US.win32.installer-stub.exe

I don't know why yet, but for some reason this did not get signed.
(Assignee)

Comment 8

10 months ago
Created attachment 8855639 [details] [diff] [review]
Part 0 - Configure for official branding and build stub installer (take 2)

This system-wide override will apply to all builds, instead of just patching win32 and breaking all others.
Attachment #8854973 - Attachment is obsolete: true
Attachment #8855639 - Flags: review?(mhowell)

Updated

10 months ago
Attachment #8855639 - Flags: review?(mhowell) → review+

Comment 9

10 months ago
Adam asked me to re-land this to oak since the first push a) didn't get signed builds, and b) broke most of the builds. So that's incoming now.
(Assignee)

Comment 11

9 months ago
A signed build for testing is up at:

https://archive.mozilla.org/pub/firefox/nightly/2017/04/2017-04-08-04-02-02-oak/firefox-55.0a1.en-US.win32.installer-stub.exe

If this is satisfactory we can then move on to getting parts 1 & 2 onto a release branch, I'll be posting the small patches to set the funnelcake versions shortly.
(Assignee)

Comment 12

9 months ago
Created attachment 8857207 [details] [diff] [review]
Funnelcake version 110
Attachment #8857207 - Flags: review?(mhowell)
(Assignee)

Comment 13

9 months ago
Created attachment 8857208 [details] [diff] [review]
Funnelcake version 111
Attachment #8857208 - Flags: review?(mhowell)
(Assignee)

Comment 14

9 months ago
Created attachment 8857209 [details] [diff] [review]
Funnelcake version 112
Attachment #8857209 - Flags: review?(mhowell)
(Assignee)

Comment 15

9 months ago
Created attachment 8857210 [details] [diff] [review]
Funnelcake version 113
Attachment #8857210 - Flags: review?(mhowell)
(Assignee)

Comment 16

9 months ago
Sorry for the flood of patches here, this series is to set the funnelcake version that the stub installer will download. They're trivial one-line changes to the FunnelcakeVersion define in browser/installer/windows/nsis/defines.nsi.in

The intended use is, starting with a branch from 53,
1. Apply 110 (no funnelcake -> 110)
2. Tag, build 110

3. Apply Part 1
4. Apply Part 2
5. Apply 111 (110 -> 111)
6. Tag, build 111

7. Apply 112 (111 -> 112)
8. Tag, build 112

9. Apply 113 (112 -> 113)
10. Tag, build 113

This covers the whole range of 110/111/112/113 for the experiment in bug 1348127, to keep things a little simpler.

Updated

9 months ago
Attachment #8857207 - Flags: review?(mhowell) → review+

Updated

9 months ago
Attachment #8857208 - Flags: review?(mhowell) → review+

Updated

9 months ago
Attachment #8857209 - Flags: review?(mhowell) → review+

Updated

9 months ago
Attachment #8857210 - Flags: review?(mhowell) → review+
I've created FUNNELCAKE_110_111_112_113_BRANCH in mozilla-release to land these, branching from https://hg.mozilla.org/releases/mozilla-release/rev/14507f1d52c6692dec4aa09ec866e1e72a553ab0. This is after RC1 (aka build3) and where we think RC2 will come from.

(In reply to Adam Gashlin [:agashlin] from comment #16)
> The intended use is, starting with a branch from 53,
> 1. Apply 110 (no funnelcake -> 110)
> 2. Tag, build 110

https://hg.mozilla.org/releases/mozilla-release/rev/d019a5e19104b6200d39b55ee77a5ba0b18b462b
https://hg.mozilla.org/releases/mozilla-release/rev/aef4d51da8137e5daedbfcca2191f867dff31c73
https://treeherder.mozilla.org/#/jobs?repo=mozilla-release&revision=aef4d51da8137e5daedbfcca2191f867dff31c73

> 3. Apply Part 1
> 4. Apply Part 2
> 5. Apply 111 (110 -> 111)
> 6. Tag, build 111

https://hg.mozilla.org/releases/mozilla-release/rev/456e793bfb4d5ff31243496465be3b64fd8ce713
https://hg.mozilla.org/releases/mozilla-release/rev/4956d453baaf1bf2bf036bc043ef8a405624007c
https://hg.mozilla.org/releases/mozilla-release/rev/3ea5a4d86d2c2f6931f50b852f675fe653419938
https://hg.mozilla.org/releases/mozilla-release/rev/2e1e2261646d8dd439a8ff0c95a7941ae81a4f95
https://treeherder.mozilla.org/#/jobs?repo=mozilla-release&revision=2e1e2261646d8dd439a8ff0c95a7941ae81a4f95

> 7. Apply 112 (111 -> 112)
> 8. Tag, build 112

https://hg.mozilla.org/releases/mozilla-release/rev/2400d95c84fc75d7be76e4188e1aba5fbd611b56
https://hg.mozilla.org/releases/mozilla-release/rev/3ac3d1ed7add4f584ccdbd6f0763054127850bba
https://treeherder.mozilla.org/#/jobs?repo=mozilla-release&revision=3ac3d1ed7add4f584ccdbd6f0763054127850bba

> 9. Apply 113 (112 -> 113)
> 10. Tag, build 113

https://hg.mozilla.org/releases/mozilla-release/rev/f8596eaec9c9354f57d6627e9ef4d314537a025d
https://hg.mozilla.org/releases/mozilla-release/rev/757300c29812079e4f2f7371a2c70336cc9ed70e
https://treeherder.mozilla.org/#/jobs?repo=mozilla-release&revision=757300c29812079e4f2f7371a2c70336cc9ed70e

Builds were kicked off using the buildbot UI.
The builds were green and I moved the stub installers to

https://archive.mozilla.org/pub/firefox/candidates/53.0-candidates/build5/partner-repacks/funnelcake110/v1/win32/en-US/Firefox%20Setup%20Stub%2053.0.exe

and so on for funnelcake111-113. We can't really test them until the first funnelcake builds from bug 1348127 are ready.
Justin, can we make sure we test this too when the funnelcake builds from 1348127 are ready?
Flags: needinfo?(jwilliams)
Yes, we can do that. I will leave my ni flag active so that I am reminded. Thanks
What exactly am I looking for while testing the stub installer with Funnelcake?

The user story from bug 1328445 and verify that bug 1350405 is fixed?

I just want to get some clarification before I sign off on the Funnelcake build. Thanks
Flags: needinfo?(jwilliams) → needinfo?(agashlin)
(Assignee)

Comment 22

9 months ago
Yes, those bugs are what we're looking for. The "Firefox Installer" file name change mentioned in bug 1328445 isn't done on our end.

You won't be able to completely test the final builds referred to in comment 18 just yet, as they are looking for the full installers for each funnelcake on bouncer. You can use the build in comment 11, though it will just install a normal release build.

It may make sense to not waste your time on this yet, and just use the proper builds in comment 18 once the full installer repacks from bug 1348127 are on bouncer. I'd strongly recommend testing the proper builds for final confirmation in any case, once that is possible.

For easy clicking these are the proper builds in question:
110
https://archive.mozilla.org/pub/firefox/candidates/53.0-candidates/build5/partner-repacks/funnelcake110/v1/win32/en-US/Firefox%20Setup%20Stub%2053.0.exe

111
https://archive.mozilla.org/pub/firefox/candidates/53.0-candidates/build5/partner-repacks/funnelcake111/v1/win32/en-US/Firefox%20Setup%20Stub%2053.0.exe

112
https://archive.mozilla.org/pub/firefox/candidates/53.0-candidates/build5/partner-repacks/funnelcake112/v1/win32/en-US/Firefox%20Setup%20Stub%2053.0.exe

113
https://archive.mozilla.org/pub/firefox/candidates/53.0-candidates/build5/partner-repacks/funnelcake113/v1/win32/en-US/Firefox%20Setup%20Stub%2053.0.exe
Flags: needinfo?(agashlin)
Hey Adam! Aki just finished with the production builds of the tour notification funnelcakes. Justin is ready to do final testing of the build with the fixes of this stub installer. Can you coordinate with Justin on what needs to be tested? :)

https://bugzilla.mozilla.org/show_bug.cgi?id=1348127#c124
Flags: needinfo?(jwilliams)
Flags: needinfo?(agashlin)
(Assignee)

Comment 24

9 months ago
We really just need to test installing on any relevant platforms, making sure that it does not set as default (I did a quick test with 32-bit Win 7 & 64-bit Win 10 just now and everything seems to be going smoothly). I don't know what specific tests are applicable as I'm not familiar with the expected behavior of the funnelcake repacks.
Flags: needinfo?(agashlin)
(Assignee)

Updated

9 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(jwilliams)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.