Closed Bug 1353947 Opened 5 years ago Closed 4 years ago

Concurrent gUM from different cameras w/same audio freezes/fails to appear

Categories

(Core :: Audio/Video: cubeb, defect, P2)

54 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1404977

People

(Reporter: jib, Unassigned)

References

Details

(Keywords: regression, stale-bug)

STR:
1. Attach a USB camera (I used Logitech C920)
2. Choose its mic as default in System Preferences / Sound / Input
3. Open https://jsfiddle.net/jib1/detvnpoa/ in two tabs (share cams/mics).

Each page has 4 videos. The first two are video-only, from each camera.
The second two repeat that pattern, but with default audio added.

Expected result:

4 videos in each tab, from the two cams in ABAB pattern, all in smooth 30 fps.

Actual result:

Tab 1:
 * 4 videos from the two cams in ABAB pattern, in smooth 30 fps.

Tab 2:
 * First two videos play at ~5 fps.
 * 3rd video is missing.
 * 4th video is frozen.

This reproduces for me 100% in mozregression and 54. Regression range:

23:42.48 INFO: Last good revision: c807c80d954a7761c3aae2036d3a1c4d3b55ba51
23:42.48 INFO: First bad revision: 1fbff6defb481238929060e04b330e5870b013be
23:42.48 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c807c80d954a7761c3aae2036d3a1c4d3b55ba51&tochange=1fbff6defb481238929060e04b330e5870b013be

In Nightly it seems more intermittent, sometimes requiring a third tab before I see problems.
See Also: → 1338521
See Also: → 1355306
Rank: 17
This is a P1 bug without an assignee. 

P1 are bugs which are being worked on for the current release cycle/iteration/sprint. 

If the bug is not assigned by Monday, 28 August, the bug's priority will be reset to '--'.
Keywords: stale-bug
Mass change P1->P2 to align with new Mozilla triage process
Priority: P1 → P2
This works for me now. I'm going to assume bug 1404977 fixed this.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404977
You need to log in before you can comment on or make changes to this bug.