Closed Bug 1354196 Opened 3 years ago Closed 3 years ago

[e10s] The text does not show in <select> options

Categories

(Core :: Layout: Form Controls, defect)

55 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: over68, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

1. Download and extracts the archive https://onedrive.live.com/download?cid=F96BA52A2AF70D03&resid=F96BA52A2AF70D03%211221&authkey=AITkrKeTDOkSYTM.
2. Open index.htm
3. Open the <select> element.


Actual results:

The text does not show in <select> options.

Screenshot https://1drv.ms/i/s!AgMN9yoqpWv5iUY-ejyVFOQIbJaC
Flags: needinfo?(jaws)
This data URI reproduces the bug:
data:text/html,<style>select { color: rgba(0, 0, 0, 0); text-shadow: 0 0 0 black; }</style><select><option>test<option>test<option>test<option>test

The problem here is that we display the text as transparent but we don't display the text-shadow. This data URI also has the same issue on Chrome.

The testcase attached from a real site only applies this style for Firefox (using `@-moz-document url-prefix()`). On Chrome they just use a set `color`.

We can't simply remove the alpha component of the color, and effectively treat rgba(0,0,0,0) as rgb(0,0,0). The site will not be expecting black instead of transparent and the black text may be unreadable too.

One solution here would be to forward the text-shadow property, though I'm wary of the ever-expanding set of CSS properties we will need to support.

The other solution would be to let the site find that it no longer works and then they can update their site to remove the special Firefox styling. Though there could be a long tail of sites that will be broken and either won't update timely or will never update.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Comment on attachment 8856679 [details]
Bug 1354196 - Forward the text-shadow CSS property to the select popup for styling.

https://reviewboard.mozilla.org/r/128620/#review131654
Attachment #8856679 - Flags: review?(dtownsend) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7545a6eab53b
Forward the text-shadow CSS property to the select popup for styling. r=mossop
https://hg.mozilla.org/mozilla-central/rev/7545a6eab53b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Please request Aurora approval on this when you get a chance.
Flags: needinfo?(jaws)
Please request beta approval because FF 54 is beta now.
Comment on attachment 8856679 [details]
Bug 1354196 - Forward the text-shadow CSS property to the select popup for styling.

Approval Request Comment
[Feature/Bug causing the regression]: regression from bug 910022
[User impact if declined]: some <select> popups on websites may be unreadable
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no, automated test covers this
[List of other uplifts needed for the feature/fix]: yes, bug 1355078 should also be included in uplift
[Is the change risky?]: not expected
[Why is the change risky/not risky?]: The change is focused specifically on select dropdowns and is a very specific/focused fix.
[String changes made/needed]:
Flags: needinfo?(jaws)
Attachment #8856679 - Flags: approval-mozilla-beta?
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #9)
> [String changes made/needed]: none
Comment on attachment 8856679 [details]
Bug 1354196 - Forward the text-shadow CSS property to the select popup for styling.

Fix a select dropdown issue and include test. Beta54+. Should be in 54 beta 3.
Attachment #8856679 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to (Away 3 May - 5 May) Jared Wein [:jaws] (please needinfo? me) from comment #9)
> [Is this code covered by automated tests?]: yes
> [Has the fix been verified in Nightly?]: no
> [Needs manual test from QE? If yes, steps to reproduce]: no, automated test
> covers this

Setting qe-verify- based on Jared's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
Depends on: 1416733
You need to log in before you can comment on or make changes to this bug.