Closed Bug 1355078 Opened 3 years ago Closed 3 years ago

[e10s] Open drop-down list leads to scroll to top the menu

Categories

(Core :: Layout: Form Controls, defect)

55 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed
firefox55 + fixed

People

(Reporter: over68, Assigned: jaws)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

1. Go to https://onedrive.live.com/download?cid=F96BA52A2AF70D03&resid=F96BA52A2AF70D03%211230&authkey=APV6opUddR6eXic.
2. Open the <select> element.


Actual results:

Open drop-down list leads to scroll to top the menu.

Screenshot https://1drv.ms/i/s!AgMN9yoqpWv5iU8UcwBfI4uhku3i
Flags: needinfo?(jaws)
Blocks: e10s-select
This reduced testcase reproduces the problem,
data:text/html,<style>select { transition: all .2s linear; } select:focus { color: purple; }</style><select><option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option>test<option selected="true">test

It looks like the call to _update is not maintaining the scroll position.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Tracking 55+ for this form controls regression.
Comment on attachment 8856820 [details]
Bug 1355078 - Restore scroll position after updating select popup.

https://reviewboard.mozilla.org/r/128744/#review131650
Attachment #8856820 - Flags: review?(dtownsend) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64ba6efd9722
Restore scroll position after updating select popup. r=mossop
https://hg.mozilla.org/mozilla-central/rev/64ba6efd9722
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Comment on attachment 8856820 [details]
Bug 1355078 - Restore scroll position after updating select popup.

Approval Request Comment
[Feature/Bug causing the regression]: regression from bug 910022
[User impact if declined]: long popups on websites will scroll away from the selected option on opening
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no, automated test covers this
[List of other uplifts needed for the feature/fix]: yes, bug 1354196 should also be included in uplift (this patch should apply on top of the patch from bug 1354196)
[Is the change risky?]: not expected
[Why is the change risky/not risky?]: The change is focused specifically on select dropdowns and is a very specific/focused fix.
[String changes made/needed]:
Attachment #8856820 - Flags: approval-mozilla-beta?
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #8)
> [String changes made/needed]: none
Comment on attachment 8856820 [details]
Bug 1355078 - Restore scroll position after updating select popup.

Fix a select dropdown issue and include test. Beta54+. Should be in 54 beta 3.
Attachment #8856820 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1359263
(In reply to (Away 3 May - 5 May) Jared Wein [:jaws] (please needinfo? me) from comment #8)
> [Is this code covered by automated tests?]: yes
> [Has the fix been verified in Nightly?]: no
> [Needs manual test from QE? If yes, steps to reproduce]: no, automated test
> covers this

Setting qe-verify- based on Jared's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.