Crash on IMAP compact of large number of messages deleted

RESOLVED DUPLICATE of bug 1316416

Status

Thunderbird
Folder and Message Lists
--
critical
RESOLVED DUPLICATE of bug 1316416
11 months ago
10 months ago

People

(Reporter: Jacques Amar, Unassigned)

Tracking

({crash})

52 Branch
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
Created attachment 8856135 [details]
thunderbird crash.txt

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Deleted a lot of emails on IMAP, then pressed compact


Actual results:

Crash


Expected results:

Compact and deleted messages disappear
(Reporter)

Comment 1

11 months ago
Tried in safe mode. -> still crash
Tried with no deleted messages -> still crash
Tried File->Compact Folders -> dies on large folder

https://crash-stats.mozilla.com/report/index/bp-4f7e7dba-10ed-4711-9b40-13f7f2170408
https://crash-stats.mozilla.com/report/index/bp-e6c0599e-f2f7-4e0b-8f73-290a02170408

Comment 2

11 months ago
likely bug 1316416

bp-e6c0599e-f2f7-4e0b-8f73-290a02170408

 0 	xul.dll	js::SavedStacks::insertFrames(JSContext*, js::FrameIter&, JS::MutableHandle<js::SavedFrame*>, mozilla::Variant<JS::AllFrames, JS::MaxFrames, JS::FirstSubsumedFrame>&&)	js/src/vm/SavedStacks.cpp:1247
1 	xul.dll	js::SavedStacks::saveCurrentStack(JSContext*, JS::MutableHandle<js::SavedFrame*>, mozilla::Variant<JS::AllFrames, JS::MaxFrames, JS::FirstSubsumedFrame>&&)	js/src/vm/SavedStacks.cpp:1152
2 	xul.dll	JS::CaptureCurrentStack(JSContext*, JS::MutableHandle<JSObject*>, mozilla::Variant<JS::AllFrames, JS::MaxFrames, JS::FirstSubsumedFrame>&&)	js/src/jsapi.cpp:6761
3 	xul.dll	CaptureStack	js/src/jsexn.cpp:244
4 	xul.dll	js::ErrorToException(JSContext*, JSErrorReport*, JSErrorFormatString const* (*)(void*, unsigned int), void*)	js/src/jsexn.cpp:552
5 	xul.dll	xul.dll@0x1c5a34f	
6 	xul.dll	js::ReportErrorNumberVA(JSContext*, unsigned int, JSErrorFormatString const* (*)(void*, unsigned int), void*, unsigned int, js::ErrorArgumentsType, char*)	js/src/jscntxt.cpp:693
7 	xul.dll	JS_ReportErrorNumberASCII(JSContext*, JSErrorFormatString const* (*)(void*, unsigned int), void*, unsigned int, ...)	js/src/jsapi.cpp:5598
8 	xul.dll	js::ReportOverRecursed(JSContext*)	js/src/jscntxt.cpp:272
9 	xul.dll	js::RunScript(JSContext*, js::RunState&)	js/src/vm/Interpreter.cpp:364
10 	xul.dll	js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct)	js/src/vm/Interpreter.cpp:477
11 	xul.dll	InternalCall	js/src/vm/Interpreter.cpp:504
12 	xul.dll	js::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, js::AnyInvokeArgs const&, JS::MutableHandle<JS::Value>)	js/src/vm/Interpreter.cpp:523
13 	xul.dll	JS::GCVector<JS::Value, 8, js::TempAllocPolicy>::trace(JSTracer*)	C:/builds/moz2_slave/tb-rel-c-esr52-w32_bld-0000000/build/objdir-tb/dist/include/js/GCVector.h:131
14 	xul.dll	XPCConvert::NativeArray2JS(JS::MutableHandle<JS::Value>, void const**, nsXPTType const&, nsID const*, unsigned int, nsresult*)	js/xpconnect/src/XPCConvert.cpp:1296
15 	xul.dll	nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)	js/xpconnect/src/XPCWrappedJSClass.cpp:1213
16 	xul.dll	nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS*, unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)	js/xpconnect/src/XPCWrappedJSClass.cpp:1213
17 	xul.dll	nsAString_internal::ReplacePrep(unsigned int, unsigned int, unsigned int)	xpcom/string/nsTSubstring.cpp:197
18 	mozglue.dll	arena_dalloc_small	memory/mozjemalloc/jemalloc.c:4592
19 	xul.dll	nsACString_internal::Equals(nsACString_internal const&)	xpcom/string/nsTSubstring.cpp:755
20 	xul.dll	NS_TableDrivenQI(void*, nsID const&, void**, QITableEntry const*)	xpcom/glue/nsISupportsImpl.cpp:17
21 	xul.dll	nsMsgMailSession::QueryInterface(nsID const&, void**)	C:/builds/moz2_slave/tb-rel-c-esr52-w32_bld-0000000/build/mailnews/base/src/nsMsgMailSession.cpp:36
22 	xul.dll	nsComponentManagerImpl::GetServiceByContractID(char const*, nsID const&, void**)	xpcom/components/nsComponentManager.cpp:1476
23 	xul.dll	nsMsgDBFolder::NotifyPropertyFlagChanged(nsIMsgDBHdr*, nsIAtom*, unsigned int, unsigned int)	C:/builds/moz2_slave/tb-rel-c-esr52-w32_bld-0000000/build/mailnews/base/util/nsMsgDBFolder.cpp:4997
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Depends on: 1316416
Keywords: crash
Resolution: --- → DUPLICATE
Duplicate of bug: 1316416

Updated

10 months ago
No longer depends on: 1316416
You need to log in before you can comment on or make changes to this bug.