Crash in java.lang.NullPointerException: Attempt to invoke interface method ''java.lang.String java.lang.CharSequence.toString()'' on a null object reference at org.mozilla.gecko.BrowserApp.updateAddonMenuItem(BrowserApp.java)

RESOLVED FIXED in Firefox 53

Status

()

Core
General
--
critical
RESOLVED FIXED
2 months ago
27 days ago

People

(Reporter: marcia, Assigned: jchen)

Tracking

({crash})

54 Branch
mozilla55
Unspecified
Android
crash
Points:
---

Firefox Tracking Flags

(firefox53blocking verified, firefox54+ fixed, firefox55 fixed, firefox-esr52 unaffected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
This bug was filed from the Socorro interface and is 
report bp-3b106b53-c0b6-4358-9bee-034482170408.
=============================================================

This came from calixte's startup crash report - there was a spike detected in this signature as well as java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp.updateAddonMenuItem(BrowserApp.java): http://bit.ly/2oVL8of

Crashes were first seen using: 20170407075218 

Possible regression ranged based on Build ID: https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=f09f78db26a594b76139cee19a2487f9509d92ee&tochange=92ba21762445f89ae0691c4eab0746ca1cb819c2

This report from a user running a Nexus 6P has a comment which says: After recent version updates open loop crash upon open

ni on snorp for help
Flags: needinfo?(snorp)
-> timdream for frontend assignee

Jim, do you think this is fallout from the event dispatcher changes?
Flags: needinfo?(timdream)
Flags: needinfo?(snorp)
Flags: needinfo?(nchen)
(Assignee)

Comment 2

a month ago
Looks like it's the "Bluhell Firewall" addon that's causing the crash, because it uses an invalid name when adding a menu item, which we ignored previously.
Flags: needinfo?(nchen)
(In reply to Jim Chen [:jchen] [:darchons] from comment #2)
> Looks like it's the "Bluhell Firewall" addon that's causing the crash,
> because it uses an invalid name when adding a menu item, which we ignored
> previously.

Based on the range and this comment, sounds like a fallout from your patch? Will you be able to get to it? Thanks.
Flags: needinfo?(timdream) → needinfo?(nchen)
(Assignee)

Updated

a month ago
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
This also affects beta and may turn out to be a bad issue on release. What patch do you think caused the problem? Must be something we uplifted for beta 11.
status-firefox53: --- → affected
Flags: needinfo?(timdream)
Flags: needinfo?(nchen)
Presumably bug 1349612?
Blocks: 1349612
tracking-firefox53: --- → ?
tracking-firefox54: --- → ?
(Assignee)

Comment 6

a month ago
Created attachment 8858080 [details] [diff] [review]
Guard again null menu item names (v1)

I only see this crash coming from installations with the "Bluhell Firewall"
addon, which uses an invalid menu item name, so the impact should not be
widespread. This simple patch fixes the issue.
Attachment #8858080 - Flags: review?(s.kaspari)
Tracking to keep an eye on this after 53 release. I'm not considering it a release blocker though.
tracking-firefox53: ? → +
tracking-firefox54: ? → +
Flags: needinfo?(timdream)
Attachment #8858080 - Flags: review?(s.kaspari) → review+

Comment 8

a month ago
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d64ffb5d7192
Guard against null menu item names; r=sebastian

Comment 9

a month ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d64ffb5d7192
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Can we request uplift to beta 54 and release 53 ASAP?  also, QA verification would be good
(Assignee)

Comment 11

a month ago
Comment on attachment 8858080 [details] [diff] [review]
Guard again null menu item names (v1)

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1321418
[User impact if declined]: Crash when using "Bluhell Firewall" add-on (and possibly other add-ons).
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small patch that only serves to avoid the crash.
[String changes made/needed]: None
Flags: needinfo?(nchen)
Attachment #8858080 - Flags: approval-mozilla-beta?
Attachment #8858080 - Flags: approval-mozilla-aurora?
Attachment #8858080 - Flags: approval-mozilla-aurora? → approval-mozilla-release?
Comment on attachment 8858080 [details] [diff] [review]
Guard again null menu item names (v1)

Fix a crash. Beta54+. Should be in 54 beta 1.
Attachment #8858080 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
pushed: https://hg.mozilla.org/releases/mozilla-beta/rev/9a10a8b7cf4f - Jim Chen - Bug 1354911 - Guard against null menu item names; r=sebastian. a=gchang
status-firefox54: affected → fixed
30K crashes in Firefox 53 last week with this signature. We should uplift this to release in preparation for a dot release.
tracking-firefox53: + → blocking
Comment on attachment 8858080 [details] [diff] [review]
Guard again null menu item names (v1)

Let's land this on m-r and verify it there too.
Attachment #8858080 - Flags: approval-mozilla-release? → approval-mozilla-release+

Comment 16

a month ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-release/rev/51b7cb864d3e
status-firefox53: affected → fixed
status-firefox-esr52: --- → unaffected
Devices:
 - LG G4 (Android 5.1.1);
 - Honor 8 (Android 6.0);
 - HTC 10 (Android 7.0);
 - Asus ZenPad 8 (Android 6.0.1).

Build: 53.0.1 (Build 2)

Based on Comment 2, I've verified this issue by disabling/enabling, opening and closing Firefox with the BluHell addon installed and everything seems to be fine, Firefox did not crash when initially installing the addon, all of the pages load correctly and none of the devices I've tested on have crashed.
status-firefox53: fixed → verified
You need to log in before you can comment on or make changes to this bug.