Report site issue button disabled in Fennec Nightly and Aurora

VERIFIED FIXED in Firefox 53

Status

()

defect
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: adamopenweb, Assigned: jchen)

Tracking

({regression})

Trunk
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec53+, firefox52 unaffected, firefox-esr52 unaffected, firefox53 fixed, firefox54 verified, firefox55 verified)

Details

Attachments

(1 attachment)

Steps to reproduce:
1) Open Firefox for Android, Nightly (55) or Aurora (54)
2) Navigate to a website to report a bug eg. https://www.mozilla.org/
3) Press 3 dot menu button

Expected behavior:
Report Site Issue button is enabled - can tap it

Actual behavior
Report Site Issue button is disabled - unable to report bugs
Summary: Report site issue button disabled in Nightly and Aurora → Report site issue button disabled in Fennec Nightly and Aurora
I wonder if mozregression can show what changed here. Unfortunately my phone exploded at dinner tonight... gonna see if I can get the screen repaired at a local shop tomorrow. >_<
It still happens both on latest nightly(55) and aurora(54).
mozregression pointed me at Bug 1321418...

Jim, does anything come to mind why that changeset would bust the menu being enabled/disabled? The code that controls that is here:

https://dxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/WebcompatReporter.js#41-59

(also yeah, I should have written a test for this... >_>)
Blocks: 1321418
Flags: needinfo?(nchen)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
I accidentally landed this patch over in bug 1321418, but it really belongs in
this bug.
Attachment #8854989 - Flags: review+
Product: Web Compatibility → Firefox for Android
Version: unspecified → Trunk
tracking-fennec: --- → ?
Comment on attachment 8854989 [details] [diff] [review]
Update menu items using the correct ID (v1)

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1321418
[User impact if declined]: Addons are not able to update the state of custom menu items; some addons like the webcompat reporter rely on this feature.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It's a small patch that only fixes the regression
[String changes made/needed]: None
Attachment #8854989 - Flags: approval-mozilla-beta?
Attachment #8854989 - Flags: approval-mozilla-aurora?
(In reply to Jim Chen [:jchen] [:darchons] from comment #4)
> I accidentally landed this patch over in bug 1321418, but it really belongs
> in this bug.

https://hg.mozilla.org/mozilla-central/rev/84abf2ef2fab
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
tracking-fennec: ? → 53+
Hi :adamopenweb,
Can you help check if this issue is fixed in the latest nightly?
Flags: qe-verify+
Flags: needinfo?(astevenson)
Comment on attachment 8854989 [details] [diff] [review]
Update menu items using the correct ID (v1)

Last minute fix on beta 53 for a race condition, along with work from bug 1351964.
Attachment #8854989 - Flags: approval-mozilla-beta?
Attachment #8854989 - Flags: approval-mozilla-beta+
Attachment #8854989 - Flags: approval-mozilla-aurora?
Attachment #8854989 - Flags: approval-mozilla-aurora+
I can verify the issue is resolved in Nightly. The report site issue button is working, screenshot upload is as well.

Thanks!
Status: RESOLVED → VERIFIED
Flags: needinfo?(astevenson)
I can confirm this issue is verified for Nightly 55.0a1 and Aurora 54.0a2, the "report site issue" button works as expected. 
On Beta 53.0b11 and the release build, the button is not present in the menu.
Depends on: 1354911
This is broken again for me on Nightly.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Caused by bug 1331742, which has since been backed out.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.