Closed Bug 1355126 Opened 3 years ago Closed 3 years ago

Wrong URL of source map location in DevTools

Categories

(DevTools :: Debugger, defect, P2)

55 Branch
defect

Tracking

(firefox55 fixed)

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: czerny.jakub, Assigned: tromey)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image screenshot.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170410100144

Steps to reproduce:

Tab of source code in dev tools remains blank after opening for source file of GWT application debugged using Super Dev Mode. (I met this problem in context of GWT, I guess it's related to the fact that Super Dev Mode locates source maps to different server than the webpages themselves.

1. Run a gwt app
2. Run GWT Development Mode (~ start debugging user super dev mode)
3. Load app in Firefox
4. Run "Dev mode On" GWT bookmarklet, click Compile button, wait for compilation of the compilation
5. Open DevTools, Debugger tab
6. Open file http://127.0.0.1:9876/sourcemaps/webadmin/http:/127.0.0.1:9876/sourcemaps/webadmin/com/google/gwt/core/client/GWT.java (select it in left sidepanel tree) in dev tools

Gwt debugger console logs following problem:
"[INFO] GET /sourcemaps/webadmin/http:/127.0.0.1:9876/sourcemaps/webadmin/com/google/gwt/core/client/GWT.java
[INFO]    [WARN] ignored get request: /sourcemaps/webadmin/http:/127.0.0.1:9876/sourcemaps/webadmin/com/google/gwt/core/client/GWT.java"

55.0a1 (2017-04-10) (64-bit), Linux
Built from https://hg.mozilla.org/mozilla-central/rev/731639fccc709a4dd95fed7e9dda88efb2227906


Actual results:

"GWT.java" source tab opens, however it's empty. Also when tab is right clicked and "Copy link address" is selected, the clipboard is filled by "http://127.0.0.1:9876/sourcemaps/webadmin/http:/127.0.0.1:9876/sourcemaps/webadmin/com/google/gwt/core/client/GWT.java"

I found suspicious that part of the URL, "/127.0.0.1:9876/sourcemaps" is repeated twice


Expected results:

Original source is shown
Last two lines of compiles source:

//# sourceMappingURL=http://127.0.0.1:9876/sourcemaps/webadmin/706FE7D9AF32CEABC6306C4DF10616B4_sourcemap.json 
//# sourceURL=webadmin-0.js
Blocks: source-maps
Component: Untriaged → Developer Tools: Debugger
Priority: -- → P2
Duplicate of this bug: 1357659
I was able to reproduce this with the GWT sample web app, just following the directions here:
http://www.gwtproject.org/gettingstarted.html
Assignee: nobody → ttromey
Status: UNCONFIRMED → NEW
Ever confirmed: true
The bug is that devtools-source-map isn't resolving URLs according to the spec.
I'll fix there and then land a new bundle to fix this bug.
Depends on: 1367836
FYI, not closing this as a dup, since I plan to land a regression test in this bug.
Duplicate of this bug: 907440
Comment on attachment 8872734 [details]
Bug 1355126 - regression test for absolute sourceRoot;

https://reviewboard.mozilla.org/r/144262/#review148022

::: devtools/client/framework/test/browser_source_map-absolute.js:11
(Diff revision 1)
> +"use strict";
> +
> +// Empty page
> +const PAGE_URL = `${URL_ROOT}doc_empty-tab-01.html`;
> +const JS_URL = `${URL_ROOT}code_binary_search_absolute.js`;
> +const ORIGINAL_URL = `${URL_ROOT}code_binary_search.coffee`;

Do you think it makes sense to include the original .coffee file in the commit as well for extra context and in case we want to modify it for another test?
Attachment #8872734 - Flags: review?(bgrinstead) → review+
Comment on attachment 8872734 [details]
Bug 1355126 - regression test for absolute sourceRoot;

https://reviewboard.mozilla.org/r/144262/#review148022

> Do you think it makes sense to include the original .coffee file in the commit as well for extra context and in case we want to modify it for another test?

The coffee file is already there, this test is just a slightly modified copy of the existing `code_binary_search.js`.
I should probably test one that's been rebased on the bug fix...
Pushed by ttromey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/657e72f1f725
regression test for absolute sourceRoot; r=bgrins
https://hg.mozilla.org/mozilla-central/rev/657e72f1f725
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.