Closed Bug 1355475 Opened 3 years ago Closed 3 years ago

Update webrender to 07b6c6a1f93b5d8af1dd9ae825906dcf5c310810

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(5 files)

+++ This bug was initially created as a clone of Bug #1353484 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 2625654b435ebba0815379dc6fba42415e3abc2b

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e6f4fe7cdfc50e8bb283f9d89ee94473471cdb8e

Bustage. New changesets listed below, bustage is just from renaming push_scroll_layer to push_clip_node in eb4a04b.

*   2625654 Auto merge of #1105 - glennw:revert-inner-rect, r=jdm
|\
| * 4bf0039 Revert "Inner rectangle compute refactor"
|/
*   a2f1f4f Auto merge of #1100 - mrobinson:rename-scroll-layer-id, r=glennw
|\
| * eb4a04b Rename ScrollLayerId to ClipId
*   e27541c Auto merge of #1104 - kvark:border, r=glennw
|\
| * 86da70b Border clipping reftest
| * 19e3d47 Refactor of ps_border.fs
* 5b74bd9 Auto merge of #1103 - mrobinson:wrench-border-radius, r=glennw
* 0d05e0e Make it easier to specify border radius in wrench
WR @ 8d7392a702e50a0177c43c831188f0696a1fb420

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a73330bd0c35dd444b477103d630339b48bfc88d

R3 failure in layout/reftests/box-shadow/611574-2.html

Regression range:
* 8d7392a Auto merge of #1106 - glennw:borders-5, r=kvark
* 123a350 Introduce border corner and edge shader path.
WR @ 98d343f2d800bb62a19d7c081a0a6a39dd74607f

https://treeherder.mozilla.org/#/jobs?repo=try&revision=72ea33d84af585e22afa5c76cbd3337fa5d02f84

Bustage, from the API change in f040e81 probably. The full regression range:

*   98d343f Auto merge of #1111 - glennw:fix-zoom-cracks, r=kvark
|\
| * e3f6317 Fix cracks that can appear at high zoom factors.
* |   f31790e Auto merge of #1110 - jrmuizel:glyphs-slice, r=glennw
|\ \
| |/
|/|
| * f040e81 Change push_text to take a slice instead of Vec.
*   e01fdda Auto merge of #1109 - kvark:fetch_data, r=glennw
|\
| * 13a4249 fetch_data* helpers for the shaders
*   ea0928a Auto merge of #1107 - kvark:inner-fix, r=glennw
|\
| * 2521e77 Fixed the inner rectangle offsets
| * 6b9db3d Revive "Inner rectangle compute refactor"
* 80b6b33 Auto merge of #1108 - jrmuizel:save-flipped, r=kvark
* b7a1557 Use save_flipped to save the png
WR @ 98d343f2d800bb62a19d7c081a0a6a39dd74607f with bustage fix

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8a4dbccc0a8f7b81686b0357181a8f84c814da69

There's a new R4 failure in layout/reftests/columns/column-balancing-overflow-005.html - not sure which patch that's coming from but I'll bisect.
f31790e56778c2ef3aff8f1b037294a7c153f0c7 doesn't have the R4 failure. Therefore the R4 regression was caused by e3f6317.
For posterity here's the try push that I did at f31790e56778c2ef3aff8f1b037294a7c153f0c7:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=76c3d78f971a500cba309c201d0177673d6df6df
WR @ 9973efd033ceb40edcebea68077766a5f096cfb3

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d43afededdec762b9adde7b32efa7cb9955ca803

R3 failure was fixed by Glennn in servo/webrender#1120 but the R4 failure still persists. No new failures.
WR, still at @ 40ca6faf336609495d0125f69a644303d53cd6b5 (but rebased onto a newer gecko version)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f2b3d2c548300aaafcd6999293b1aa0d6a199265

Same as before.
I realized that the test in the R4 failure above was already marked as fuzzy-if(webrender,255,6) and the WR update just increased the fuzzy pixels from 6 to 12. The test is really testing layout of columns so a few pixels off in the outline is fine, methinks. I added a patch to my queue to update the fuzzy-if annotation.

However, the latest try run:

WR @ f687ff6c3df63a6846f7f96c71c4d76b34f7198e

https://treeherder.mozilla.org/#/jobs?repo=try&revision=06d60340deb975a1a1fa99d88fbff0647857da9b

Orange across the board! Looks like some sort of startup failure but there's not much in the log. I'm going to land an update to the last good revision (07b6c6a1f93b5d8af1dd9ae825906dcf5c310810) and spin off this orange investigation into the next update bug.
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 07b6c6a1f93b5d8af1dd9ae825906dcf5c310810
Comment on attachment 8859178 [details]
Bug 1355475 - Update call to push_text for API change in f040e81.

https://reviewboard.mozilla.org/r/131222/#review133776
Attachment #8859178 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8859177 [details]
Bug 1355475 - push_scroll_layer was renamed to push_clip_node in eb4a04b.

https://reviewboard.mozilla.org/r/131220/#review133778
Attachment #8859177 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8859176 [details]
Bug 1355475 - Update Cargo.toml/Cargo.lock files for webrender.

https://reviewboard.mozilla.org/r/131218/#review133780
Attachment #8859176 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8859175 [details]
Bug 1355475 - Update webrender and webrender_traits to 07b6c6a1f93b5d8af1dd9ae825906dcf5c310810.

https://reviewboard.mozilla.org/r/131216/#review133782
Attachment #8859175 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8859179 [details]
Bug 1355475 - Update reftest fuzziness for change in e3f6317.

https://reviewboard.mozilla.org/r/131224/#review133784
Attachment #8859179 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/ba5181e4ab58
Update webrender to 07b6c6a1f93b5d8af1dd9ae825906dcf5c310810. r=jrmuizel
https://hg.mozilla.org/projects/graphics/rev/565e21b8bc93
Update reftest fuzziness for change in webrender cset e3f6317. r=jrmuizel
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.