lsa.colorado.edu - Partial URL's with scheme and absolute path but no host resolve incorrectly

VERIFIED DUPLICATE of bug 32966

Status

Tech Evangelism Graveyard
English US
VERIFIED DUPLICATE of bug 32966
16 years ago
3 years ago

People

(Reporter: Davor Cubranic, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
POST action for the form on the above page is "http:/cgi-bin/...". This is
interpreted in Netscape 4 as "http://lsa.colorado.edu/cgi-bin/...", but Mozilla
takes me to "cgi-bin.com" -- apparently it interprets the first item in the
absolute path as a host name, even though the URL starts with a single slash.

Comment 1

16 years ago
this violates RFC 2396. not a mozilla bug.

over to evangelism
Assignee: Matti → doronr
Status: UNCONFIRMED → NEW
Component: Browser-General → US Edu
Ever confirmed: true
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: imajes-qa → caillon
Version: other → unspecified
(Reporter)

Comment 2

16 years ago
From RFC 2396:
      Due to a loophole in prior specifications [RFC1630], some parsers
      allow the scheme name to be present in a relative URI if it is the
      same as the base URI scheme.  Unfortunately, this can conflict
      with the correct parsing of non-hierarchical URI.  For backwards
      compatibility, an implementation may work around such references
      by removing the scheme if it matches that of the base URI and the
      scheme is known to always use the <hier_part> syntax.  The parser
      can then continue with the steps below for the remainder of the
      reference components.  Validating parsers should mark such a
      misformed relative reference as an error.

Even regardless of this suggestion, and the fact that one might want to keep the
Netscape 4 behaviour in this case for reasons of backwards compatibility, it
seems to me that Mozilla parser is itself not respecting RFC 2396 when it
interprets "http:/cgi-bin/..." as host name cgi-bin.com even though the URL
doesn't start with a double slash, as per RFC.

Comment 3

16 years ago
see bug 32966 which is marked wontfix

the best thing to do is for the webmaster to update their pages
(Reporter)

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 32966 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

16 years ago
Moving discussion to Bug 23966, since this is just a dupe.

Although, in my opinion, this kind of behaviour is just another nail in
Mozilla's coffin.
v
Status: RESOLVED → VERIFIED

Comment 7

15 years ago
tech evang june 2003 reorg
Component: US Edu → English US

Updated

15 years ago
Summary: Partial URL's with scheme and absolute path but no host resolve incorrectly → lsa.colorado.edu - Partial URL's with scheme and absolute path but no host resolve incorrectly
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.