Open Bug 1355537 Opened 3 years ago Updated 7 days ago

[meta] Add Python 3 support to marionette driver

Categories

(Testing :: Marionette, task, P3)

task

Tracking

(Not tracked)

People

(Reporter: markjballard, Unassigned)

References

(Depends on 3 open bugs, Blocks 2 open bugs)

Details

(Keywords: meta)

Attachments

(1 obsolete file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170329150444

Steps to reproduce:

Attemp to install marionette_driver 2.2.0. with either pip or pip3

52.0.2 (64-bit) for Ubuntu Linux, 16.04.2 LTS

Any of these commands produce the same result:

$ pip3 install marionette_driver
$ sudo pip3 install marionette_driver
$ sudo -H pip3 install marionette_driver

$ pip install marionette_driver
$ sudo pip install marionette_driver
$ sudo -H pip install marionette_driver



Actual results:

Collecting marionette_driver
  Downloading marionette_driver-2.2.0.tar.gz
Collecting mozrunner>=6.13 (from marionette_driver)
  Downloading mozrunner-6.13.tar.gz (67kB)
    100% |████████████████████████████████| 71kB 1.5MB/s
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-0829rk11/mozrunner/setup.py", line 24, in
<module>
        assert sys.version_info[0] == 2
    AssertionError
   
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in
/tmp/pip-build-0829rk11/mozrunner/



Expected results:

It should have installed marionette_driver for use with Python / 3.
marionette_driver depends on mozbase, which does not support Python 3. See bug 1093212.
Depends on: mozbase-py3
Priority: -- → P4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Error on attempt to install marionette driver with pip → Add Python 3 support to marionette driver
Priority: P4 → P5

I just checked the mozbase dependencies for bug 1093212 and as I can see all the packages as required by Marionette now have Python 3 support. That means we are no longer blocked on actually updating Marionette client to make it at least work with Python 3.

I talked to Rishi over IRC and he mentioned interest working on this bug.

Flags: needinfo?(rishigpt2009)

Please note that the requirements file for the Marionette client package might still refer to older releases of some mozbase packages. So please make sure to update the versions to the latest releases of the specific packages. As best do it in a separate commit.

Flags: needinfo?(rishigpt2009)
Assignee: nobody → rishigpt2009
Status: NEW → ASSIGNED
Depends on: 1595814

After locally taking the changes from 1595814 i tried running marionette test. There were no errors from harness or driver but from testing/mozbase/manifest. Error was in accessing dictionary items which works differently in python3. As i checked in mozilla-unified/testing/mozbase/manifestparser/setup.py. This is a python2 based library.

What should be done in this scenario as manifestparser is a mozbase package. Should i log a separate bug or enhancement on this as a dependency ?

Indeed manifestparser is still Python2 only. See bug 1428705 which handles the upgrade to Python3. But is that actually used when you reference a single .py test file? If that is not the case it shouldn't be a hard blocker for the harness. Also the driver doesn't depend on it at all.

Blocks: 1597745
Blocks: 1597737
No longer blocks: 1597737
No longer depends on: 1597687
No longer depends on: 1597690
No longer blocks: 1597745

This is actually a meta bug now which cannot be assigned to someone. Lets get any work done in dependent bugs.

Assignee: rishigpt2009 → nobody
Status: ASSIGNED → NEW
Type: defect → task
Keywords: meta
Priority: P5 → P3
Summary: Add Python 3 support to marionette driver → [meta] Add Python 3 support to marionette driver
Version: 2.0 Branch → unspecified
Assignee: nobody → rishigpt2009
Status: NEW → ASSIGNED
Attachment #9100652 - Attachment is obsolete: true
Assignee: rishigpt2009 → nobody
Status: ASSIGNED → NEW
Depends on: 1640249
You need to log in before you can comment on or make changes to this bug.