Closed Bug 1355824 Opened 3 years ago Closed 3 years ago

Browser opens a new tab for web apps already running - tabs tray shows wrong info

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P1)

55 Branch
ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox55 --- unaffected

People

(Reporter: oana.horvath, Unassigned)

References

(Blocks 1 open bug)

Details

Build: Nightly 55.0a1 (2017-04-12).
Devices:
- LG G4 (Android 5.1)
- Motorola Nexus 6 (Android 7.0)
- Huawei MediaPad M2 (Android 5.1.1)

Steps to reproduce:
1. Install a web app (e.g. Twitter)
2. Kill all browser & web app instances.
3. Start the web app.
4. Start the browser.
5. Observe the tabs counter.
6. Open the tabs tray and verify the number of tabs.

Expected result:
Nightly should restore and show the correct number of tabs.

Actual result:
**With "Always restore tabs" pref on:
4. A new tab, with the web app's page, is created each time Nightly is opened while the web app is running. 
*3 out of 5 times, Nightly crashes (crash reported on Bug 1351169).
5-6. The tabs counter is "1" when actually, there are more. 

**With "Don't restore tabs" pref on:
4&5 - same results: new tabs opened, counter is "1" (or how many web apps you have opened).
6. The tabs tray is empty.
Blocks: 1285858
At least part of this is handled in bug 1351808 and bug 1352997.
Depends on: 1351808, 1352997
Priority: -- → P1
Verified on Nightly 2017-05-03 and this bug doesn't reproduce anymore. I'll reopen it if the issue appears again.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Sorry, marking firefox-55 as unaffected since this was fixed by other bugs.
You need to log in before you can comment on or make changes to this bug.