Closed Bug 1355847 Opened 4 years ago Closed 4 years ago

Web apps - Share selected text doesn't work on Android 6+

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P1)

55 Branch
ARM
Android
defect

Tracking

(firefox55 affected)

RESOLVED DUPLICATE of bug 1360658
Tracking Status
firefox55 --- affected

People

(Reporter: oana.horvath, Assigned: cnevinchen)

References

Details

Attachments

(1 file)

Device: Android 6+ devices.
Build: Nightly 55.0a1 (2017-04-12).

Steps to reproduce:
1. Install a web app (e.g. Twiiter) and open it.
2. Long press on a word to select it.
3. Tap Share in the dialog box opened.

Expected result:
The Share action should open a list of apps to share with.

Actual result:
The Share button doesn't open the sharing apps list.
Blocks: 1285858
Priority: -- → P1
Assignee: nobody → cnevinchen
Comment on attachment 8862791 [details]
Bug 1355847 - Share selected text should work.

Just need to call super method so things in GeckoApp handleMessage can be called.
Comment on attachment 8862791 [details]
Bug 1355847 - Share selected text should work.

https://reviewboard.mozilla.org/r/134682/#review138102

LGTM
Attachment #8862791 - Flags: review?(max) → review+
Comment on attachment 8862791 [details]
Bug 1355847 - Share selected text should work.

https://reviewboard.mozilla.org/r/134682/#review138264
Attachment #8862791 - Flags: review?(walkingice0204) → review+
Comment on attachment 8862791 [details]
Bug 1355847 - Share selected text should work.

https://reviewboard.mozilla.org/r/134682/#review138354

So r+, howevet JanH already landed this in https://bugzilla.mozilla.org/show_bug.cgi?id=1360658 so I think you can close as dupe
Attachment #8862791 - Flags: review?(dale) → review+
We're sorry - something has gone wrong while rewriting or rebasing your commits. The commits being pushed no longer match what was requested. Please file a bug.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360658
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.