Closed Bug 1355998 Opened 3 years ago Closed 3 years ago

Fix & re-enable browser_inlinesettings_browser.js on Windows

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: standard8, Assigned: rhelmer)

References

Details

(Whiteboard: triaged)

Attachments

(1 file)

In landing screenshots (bug 1346825), we found an issue with browser_inlinesettings_browser.js was pretty much (not quite) perma-failing on Windows.

Typical log (from https://treeherder.mozilla.org/logviewer.html#?job_id=91025656&repo=try&lineNumber=6366):

12:02:19     INFO - Entering test bound test_inline_browser_addon
12:02:19     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/test-window/browser_inlinesettings_browser.js | view controller is tracking the displayed view correctly - 
12:02:19     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/test-window/browser_inlinesettings_browser.js | Options should be inline browser type - 
12:02:19     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/test-window/browser_inlinesettings_browser.js | Element should not be null, when checking visibility - 
12:02:19     INFO - Buffered messages logged at 12:02:11
12:02:19     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/test-window/browser_inlinesettings_browser.js | Preferences button should be visible - 


12:02:19     INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/test-window/browser_inlinesettings_browser.js | A promise chain failed to handle a rejection:  - at chrome://global/content/bindings/browser.xml:151 - Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIWebNavigation.loadURIWithOptions]
12:02:19     INFO - Stack trace:
12:02:19     INFO - JS frame :: chrome://global/content/bindings/browser.xml :: loadURIWithFlags/< :: line 151
12:02:19     INFO - JS frame :: chrome://global/content/bindings/browser.xml :: _wrapURIChangeCall :: line 43
12:02:19     INFO - JS frame :: chrome://global/content/bindings/browser.xml :: loadURIWithFlags :: line 150
12:02:19     INFO - JS frame :: chrome://global/content/bindings/browser.xml :: loadURI/< :: line 114
12:02:19     INFO - JS frame :: chrome://global/content/bindings/browser.xml :: _wrapURIChangeCall :: line 43
12:02:19     INFO - JS frame :: chrome://global/content/bindings/browser.xml :: loadURI :: line 113
12:02:19     INFO - JS frame :: chrome://mozapps/content/extensions/extensions.js :: gDetailView.createOptionsBrowser</< :: line 3678
12:02:19     INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: Promise :: line 390
12:02:19     INFO - JS frame :: chrome://mozapps/content/extensions/extensions.js :: gDetailView.createOptionsBrowser< :: line 3651
12:02:19     INFO - JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 319
12:02:19     INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: process :: line 922
12:02:19     INFO - JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: walkerLoop :: line 806
12:02:55     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 1
12:03:40     INFO - Not taking screenshot here: see the one that was previously logged
12:03:40     INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/test-window/browser_inlinesettings_browser.js | Test timed out - 


Logging showed that the URL passed to loadURIWithOptions was "moz-extension://70b66e9e-6247-406c-9b2f-755ea93bd72c/options.html".

On IRC, Rob said that it looked like the add-on created for the test was id aa69531f-2c04-4290-8efc-584533735b2a.
(In reply to Mark Banner (:standard8) from comment #0)
> Logging showed that the URL passed to loadURIWithOptions was
> "moz-extension://70b66e9e-6247-406c-9b2f-755ea93bd72c/options.html".
> 
> On IRC, Rob said that it looked like the add-on created for the test was id
> aa69531f-2c04-4290-8efc-584533735b2a.

FTR I was reading the log wrong - that was the moz-extension:// UUID so isn't helpful.
Priority: -- → P2
Whiteboard: triaged
I can't reproduce this after several tries on tryserver - I suspect delaying start of the webextension in bug 1346825 helped. What do you think Mark?
Comment on attachment 8862511 [details]
Bug 1355998 - re-enable browser_inlinesettings_browser.js on Windows. Screenshots delaying webextension startup fixes this intermittent.

https://reviewboard.mozilla.org/r/134412/#review138468

I did a try build with Screenshots enabled within tests and we still hit this failure:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e0c05d0a7cd0da5363cb049dcc7d7224e9f32997&selectedJob=95864785

https://treeherder.mozilla.org/logviewer.html#?job_id=95866141&repo=try&lineNumber=16818

So I think we should try fixing those before we re-enable this.
Attachment #8862511 - Flags: review?(standard8)
Ugh, yes I should have done my try run with screenshots enabled.
Comment on attachment 8862511 [details]
Bug 1355998 - re-enable browser_inlinesettings_browser.js on Windows. Screenshots delaying webextension startup fixes this intermittent.

https://reviewboard.mozilla.org/r/134412/#review138468

Rebasing on a relatively new mozilla-central doesn't seem to show this anymore: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ce979729295872bfaee08e601e00419bd1224406
Comment on attachment 8862511 [details]
Bug 1355998 - re-enable browser_inlinesettings_browser.js on Windows. Screenshots delaying webextension startup fixes this intermittent.

https://reviewboard.mozilla.org/r/134412/#review139316

Per discussions & further try runs, the issue seems to have gone away, so lets re-enable this and see how it goes.
Attachment #8862511 - Flags: review+
Pushed by rhelmer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/661b2bd5e032
re-enable browser_inlinesettings_browser.js on Windows. Screenshots delaying webextension startup fixes this intermittent. r=standard8
https://hg.mozilla.org/mozilla-central/rev/661b2bd5e032
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Unfortunately this still seems to be happening when screenshots is enabled for tests:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ac58b8b3c33146661ffdb796e80cd98bcd19fd03&selectedJob=96867938
Status: RESOLVED → REOPENED
Flags: needinfo?(rhelmer)
Resolution: FIXED → ---
Hm. I wonder why my try run from comment 6 didn't show it - I guess it's possible this only happens for non-debug builds :/

Once I can repro this somewhere (try or locally) I should be able to get it fixed up, thanks for the needinfo Mark.
Flags: needinfo?(rhelmer)
Hm. Well I only see this on windows 7, and only for opt builds, but I can repro it now:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9aced73760659ce7ca1d815352511b9103f7dd9e&selectedJob=97418432
OK. So this is only happening when about:addons is loaded into a window (as opposed to a browser tab), as far as I can tell:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b1dca8c87da41ffaf40445f2d1116e92c6064d41&selectedJob=97589408

I recently announced intent to remove this from our tests, because there are a number of bugs that we don't want to fix that only show up in this mode and Firefox hasn't used it for years. I'll go ahead and do that in bug 1349723.
Depends on: 1349723
Rob, should we try this again now that bug 1349723 has landed?
Flags: needinfo?(rhelmer)
(In reply to Mark Banner (:standard8) from comment #14)
> Rob, should we try this again now that bug 1349723 has landed?

Yes we should - I will try again today.
Flags: needinfo?(rhelmer)
Actually looks like we already landed this and it stuck:
https://hg.mozilla.org/mozilla-central/rev/661b2bd5e032

Please reopen if I'm mistaken.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.