Intermittent TEST-UNEXPECTED-TIMEOUT | dom/media/test/test_mediarecorder_record_upsize_resolution.html | application timed out after 330 seconds with no output

RESOLVED DUPLICATE of bug 1332845

Status

()

--
critical
RESOLVED DUPLICATE of bug 1332845
2 years ago
a year ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

14 failures in 894 pushes (0.016 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* mozilla-inbound: 2
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 13
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356113&startday=2017-04-10&endday=2017-04-16&tree=all
This happens almost always on windows 7, debug, e10s.

There is an assertion before the timeout:

18:27:46     INFO -  GECKO(2872) | Assertion failure: false, at z:/build/build/src/dom/media/encoder/VP8TrackEncoder.cpp:95
18:27:58     INFO -  GECKO(2872) | #01: mozilla::VP8TrackEncoder::PrepareRawFrame(mozilla::VideoChunk &) [dom/media/encoder/VP8TrackEncoder.cpp:376]
18:27:58     INFO -  GECKO(2872) | #02: mozilla::VP8TrackEncoder::GetEncodedTrack(mozilla::EncodedFrameContainer &) [dom/media/encoder/VP8TrackEncoder.cpp:636]
18:27:58     INFO -  GECKO(2872) | #03: mozilla::MediaEncoder::WriteEncodedDataToMuxer(mozilla::TrackEncoder *) [dom/media/encoder/MediaEncoder.cpp:337]
18:27:58     INFO -  GECKO(2872) | #04: mozilla::MediaEncoder::GetEncodedData(nsTArray<nsTArray<unsigned char> > *,nsAString &) [dom/media/encoder/MediaEncoder.cpp:279]
18:27:58     INFO -  GECKO(2872) | #05: mozilla::dom::MediaRecorder::Session::Extract(bool) [dom/media/MediaRecorder.cpp:623]
18:27:58     INFO -  GECKO(2872) | #06: mozilla::dom::MediaRecorder::Session::ExtractRunnable::Run() [dom/media/MediaRecorder.cpp:279]
18:27:58     INFO -  GECKO(2872) | #07: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1271]

which reminds me of bug 1354841 and bug 1348381.

This test was added in bug 1232043.
Blocks: 1232043
Crash Signature: [@ mach_msg_trap + 0xa] [@ mozilla::VP8TrackEncoder::Init(int, int, int, int)] → [@ mach_msg_trap + 0xa] [@ mozilla::VP8TrackEncoder::Init(int, int, int, int)]
See Also: → bug 1348381, bug 1354841
18 failures in 817 pushes (0.022 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 6
* autoland: 5
* mozilla-inbound: 4
* oak: 2
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 11
* osx-10-10: 4
* linux32: 2
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356113&startday=2017-04-17&endday=2017-04-23&tree=all
this magically was fixed or at least stopped reporting on April 25th, similar timing to bug 1354841.
Component: Audio/Video: Playback → Audio/Video: Recording
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1332845
You need to log in before you can comment on or make changes to this bug.