Intermittent dom/media/test/test_mediarecorder_principals.html | application crashed [@ mozilla::VideoTrackEncoder::AppendVideoSegment(mozilla::VideoSegment const&)] after Assertion failure: false, at dom/media/encoder/TrackEncoder.cpp:289

RESOLVED FIXED in Firefox 54

Status

()

defect
P3
normal
Rank:
35
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: pehrsons)

Tracking

({assertion, crash, intermittent-failure})

unspecified
mozilla55
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 wontfix, firefox54 fixed, firefox55 fixed)

Details

Attachments

(2 attachments)

Assignee

Updated

2 years ago
Assignee: nobody → pehrson
Rank: 35
Component: Audio/Video → Audio/Video: Recording
Priority: -- → P3
Assignee

Updated

2 years ago
See Also: → 1333271
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Any updates on this, Andreas? :)
Flags: needinfo?(pehrson)
Assignee

Comment 12

2 years ago
I'm able to reproduce.
Status: NEW → ASSIGNED
Flags: needinfo?(pehrson)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 15

2 years ago
mozreview-review
Comment on attachment 8855841 [details]
Bug 1332845 - Remove direct listeners before ending track in TrackUnionStream.

https://reviewboard.mozilla.org/r/127722/#review130462
Attachment #8855841 - Flags: review?(rjesup) → review+

Comment 16

2 years ago
mozreview-review
Comment on attachment 8855840 [details]
Bug 1332845 - Remove listeners before other cleanup in MediaRecorder.

https://reviewboard.mozilla.org/r/127720/#review130464
Attachment #8855840 - Flags: review?(rjesup) → review+
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Comment 20

2 years ago
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/76e7f2698291
Remove listeners before other cleanup in MediaRecorder. r=jesup
https://hg.mozilla.org/integration/autoland/rev/9e998b5f1d08
Remove direct listeners before ending track in TrackUnionStream. r=jesup

Comment 21

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/76e7f2698291
https://hg.mozilla.org/mozilla-central/rev/9e998b5f1d08
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Thanks for fixing this! Please nominate it for Beta approval when you get a chance :)
Flags: needinfo?(pehrson)
Assignee

Comment 23

2 years ago
Comment on attachment 8855840 [details]
Bug 1332845 - Remove listeners before other cleanup in MediaRecorder.

(In reply to Ryan VanderMeulen [:RyanVM] from comment #22)
> Thanks for fixing this! Please nominate it for Beta approval when you get a
> chance :)

Ah, I had the request written already. Was just waiting for a bit of Nightly coverage to answer that question below :-)


Approval Request Comment
[Feature/Bug causing the regression]: Bug 1332584 added the failing assert which gave discoverability. Root cause has been around for a very long time.
[User impact if declined]: Intermittent assertion failures in debug builds. No real impact in prod builds.
[Is this code covered by automated tests?]: Yes, both patches affect common code covered by a multitude of tests.
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Both patches are short, simple (only changing order of code) and easy to reason about.
[String changes made/needed]: None

This approval request applies to both patches on this bug.
Flags: needinfo?(pehrson)
Attachment #8855840 - Flags: approval-mozilla-beta?
Assignee

Updated

2 years ago
See Also: 1333271
Duplicate of this bug: 1333271
Comment on attachment 8855840 [details]
Bug 1332845 - Remove listeners before other cleanup in MediaRecorder.

Fix an intermittent failure. Beta54+. Should be in 54 beta 3.
Attachment #8855840 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee

Updated

2 years ago
Duplicate of this bug: 1354841
Assignee

Updated

2 years ago
Duplicate of this bug: 1355857
Assignee

Updated

2 years ago
Duplicate of this bug: 1356113
You need to log in before you can comment on or make changes to this bug.