Preferences search results show results from Firefox Account as not logged in

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: MikkCZ, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community})

unspecified
Firefox 56
x86_64
Linux
nightly-community
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0 ID:20170413100144 CSet: 819a666afddc804b6099ee1b3cff3a0fdf35ec15

I have enabled the experimental search a gave it a try. What I have noticed is that in the results, Firefox Account is shown as if I am not logged in to Sync. If I open the Firefox Account section before the search, it works correctly.

Steps to reproduce:
1. Open about:preferences having browser.preferences.search enabled and being logged in to Firefox Account (Sync).
2. Type "history" in the search field.

What happens:
1. At the end of the results list, Firefox Account shows as not logged in.

What should happen:
1. The results should display correct Firefox Account section.

Note:
If you open the Firefox Account section and try to search again, it will work until you close and open about:preferences again.

Updated

2 years ago
Blocks: 1357285
Whiteboard: [photon-preference]

Updated

2 years ago
Target Milestone: --- → Firefox 56

Updated

2 years ago
QA Contact: hani.yacoub

Updated

2 years ago
Flags: qe-verify+

Comment 1

2 years ago
Hi Michal,

I cannot reproduce this anymore at current m-c build (55.0a1 (2017-04-27) (64-bit)).

Could you still reproduce it?
Flags: needinfo?(mstanke)
Hi Evan.

You are right, it works for me in Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0 ID:20170427100655 CSet: 0b77ed3f26c5335503bc16e85b8c067382e7bb1e too. Should I find a commit that fixed it, or is it OK to just close this?
Flags: needinfo?(mstanke)

Comment 3

2 years ago
Hi Michal,

I think we don't need to find out the commit. Let's just set it as WORKFORME.

Thanks for filing the bug. :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Priority: -- → P1

Updated

2 years ago
Whiteboard: [photon-preference]
You need to log in before you can comment on or make changes to this bug.