6.3ms uninterruptible reflow at _updateTabsVisibilityStatus@chrome://browser/content/tabbrowser.xml:7516:1

RESOLVED WONTFIX

Status

()

enhancement
P2
normal
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: mconley, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
qe-verify ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p1])

Here's the stack:

_updateTabsVisibilityStatus@chrome://browser/content/tabbrowser.xml:7516:1
onxblpopupshowing@chrome://browser/content/tabbrowser.xml:7626:11
Looks like this is because the "List all tabs" popup wants to decorate the tabs that are actually visible in the tab strip in a particular way in the popup, so it does a layout flush to see if the tabs are within the visible region of the tab strip.
(In reply to Mike Conley (:mconley) from comment #1)
> Looks like this is because the "List all tabs" popup wants to decorate the
> tabs that are actually visible in the tab strip in a particular way in the
> popup, so it does a layout flush to see if the tabs are within the visible
> region of the tab strip.

Correct.
Component: Untriaged → Tabbed Browser
Flags: qe-verify?
Priority: -- → P2
Reporter

Updated

2 years ago
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Duplicate of this bug: 1358409
For me the reflow time is around 15 ms.
I don't think there's a way around this, and it won't affect animations or other actions that the user may be paying attention to since it only occurs while opening the all-tabs popup. Marking wontfix.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
No longer blocks: photon-performance-triage
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1]
You need to log in before you can comment on or make changes to this bug.