Should mark Private Browsing tour as completed after user clicks private-browsing tour action button

RESOLVED DUPLICATE of bug 1357021

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1357021
2 years ago
2 years ago

People

(Reporter: Fischer, Assigned: Fischer)

Tracking

unspecified
Firefox 57
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
Should mark Private Browsing tour as completed after user opens a private browsing window
(Assignee)

Updated

2 years ago
Whiteboard: [photon-onboarding]
After asking Ricky seems we have no way to know if a user have ever opened private browsing in previous version. There's no counter for that.
I'll still make some investigation.

So the worst case is that we can implement that mechanism, but we can't tell if it's used in a previous version. And after upgrading, the private browsing tour will always starts from incomplete.
Assignee: nobody → rexboy
Status: NEW → ASSIGNED
Flags: qe-verify+
QA Contact: jwilliams
Priority: -- → P1
Continue with Comment 1.

We've ever had a telemetry to trace private window usage, but they're being removed due to policies.
https://bugzilla.mozilla.org/show_bug.cgi?id=1325323

So I wonder if we're not able to tell if a user have ever used private window in older versions. We may need to start private window tour unchecked; and the tour may be only marked completed after a user opened private window from the tour overlay or a notification. How do you think about this, Verdi?
Flags: needinfo?(mverdi)
At the very least we can know if they click the button in the overlay that highlights where the private browsing feature is in the menu. So, worst case, we'll have to use that as success. I'll investigate what the policy is that has us not track private browsing usage - I don't see a reference to an actual policy anywhere.
Flags: needinfo?(mverdi)
(so we can make sure when user upgrade from the old version, it sees just the tour icon without the set default browser. But this is relatively in low priority IMO)
Sorry, please ignore comment 4. It's for another bug.
We're waiting for the update from legal team's input whether we can trace first-time use of the private window. Peter had some meeting with them last week but seems there's no simple conclusion yet. We still need further confirmation.
Priority: P1 → P2
Target Milestone: --- → Firefox 57
Priority: P2 → P1
(Assignee)

Updated

2 years ago
Assignee: rexboy → fliu
Summary: Should mark Private Browsing tour as completed after user opens a private browsing window → Should mark Private Browsing tour as completed after user clicks private-browsing tour action button
(Assignee)

Comment 7

2 years ago
This bug will be done together with Bug 1357021 so duplicate it
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357021
remove whiteboard tag due to its DUPLICATE
Whiteboard: [photon-onboarding]
You need to log in before you can comment on or make changes to this bug.