Closed Bug 1357351 (dawn-project-fennec) Opened 3 years ago Closed 3 years ago

(meta) fennec migration plan with respect to project dawn

Categories

(Firefox for Android :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: wesley_huang, Unassigned)

References

(Depends on 2 open bugs)

Details

#1 accommodate current aurora users to nightly thru google play
#2 accommodate current nightly users to uninstall the (obsolete) nightly, and then install the new nightly thru google play
Depends on: 1354821
Depends on: 1357356
Depends on: 1357358
Depends on: 1357360
Depends on: 1357362
Depends on: 1357364
Alias: dawn-project-fennec
Depends on: 1357409
(In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #0)
> #1 accommodate current aurora users to nightly thru google play
> #2 accommodate current nightly users to uninstall the (obsolete) nightly,
> and then install the new nightly thru google play

Either I'm misunderstanding, or this is an overly brief phrasing of what you plan to do, or I think this needs to be revisited.


If Nightly has the same app ID, same account ID, and same signing key, then there's no reason to uninstall; asking users to do so will simply cause them to lose data (remember that users don't get to manage profiles on Android), and we'll lose Nightly users.

And as far as I know nothing has changed about our attitude to Google Play -- it's great, but it doesn't have 100% market coverage, and it's no good for single locale builds.

I think what you're saying is:

- Nightly will be published on Google Play as org.mozilla.fennec_aurora, replacing the existing Aurora.
- We'd like to encourage existing Nightly users who use our updater to instead use the Google Play updater if they can.
- They can only do so by uninstalling "Nightly" (org.mozilla.fennec) and installing "Nightly" (org.mozilla.fennec_aurora).
- Nightly users who don't have Google Play installed, or who don't want to install via Play -- a non-trivial number -- can continue to use our updater to update org.mozilla.fennec.

If what you're saying includes one of these:

- We will no longer produce builds with the old org.mozilla.fennec ID, only with fennec_aurora
- We will no longer be serving updates via Balrog for Fennec

then I suspect further discussion is needed to avoid either orphaning or alienating existing users.

Could you clarify, Wesley?
Flags: needinfo?(whuang)
Thanks for the input. 
I'll need to discuss with Joe and eng team with considering what you listed and also the fact that Mozilla Online distributing bit not thru google play. 
Let me keep my NI for now and I'll reply soon.
(In reply to Richard Newman [:rnewman] from comment #1)
> - Nightly users who don't have Google Play installed, or who don't want to
> install via Play -- a non-trivial number -- can continue to use our updater
> to update org.mozilla.fennec.

the daily active nightly users are "very limited" in numbers so it comes down to whether it's worth building the same build twice for 2 package names and it can be confusing that you can have 2 exact same builds on your device and you couldn't quite distinguish between them. 

> If what you're saying includes one of these:
> 
> - We will no longer produce builds with the old org.mozilla.fennec ID, only
> with fennec_aurora
> - We will no longer be serving updates via Balrog for Fennec
> 
> then I suspect further discussion is needed to avoid either orphaning or
> alienating existing users.

Given the nightly daily active users are very limited and we are providing an alternative method (Google Play) to migrate the nightly users, it was discussed before the the hacks blog and the FAQ was posted that it is a hit that we are willing to take.
We should continue to provide builds users can download directly from us

Since I can't really speak for release management (but I believe we are on the same page), Sylvestre can confirm his thoughts and approach.
Flags: needinfo?(sledru)
Flags: needinfo?(whuang)
(In reply to Joe Cheng [:jcheng] (please needinfo) from comment #3)
> > If what you're saying includes one of these:
> > 
> > - We will no longer produce builds with the old org.mozilla.fennec ID, only
> > with fennec_aurora
> > - We will no longer be serving updates via Balrog for Fennec
> > 
> > then I suspect further discussion is needed to avoid either orphaning or
> > alienating existing users.
> 
> Given the nightly daily active users are very limited and we are providing
> an alternative method (Google Play) to migrate the nightly users, it was
> discussed before the the hacks blog and the FAQ was posted that it is a hit
> that we are willing to take.
> We should continue to provide builds users can download directly from us
> 
> Since I can't really speak for release management (but I believe we are on
> the same page), Sylvestre can confirm his thoughts and approach.


i'm taking back some of what I said in comment 3. Please see https://bugzilla.mozilla.org/show_bug.cgi?id=1357362#c7
I think we can continue to provide updates through both Google Play and our own updater as it is how aurora works currently. 
This however still require users to install the "new" nightly with the aurora package name.
We're making an assumption here about Google Play and users.

Does the Android open source project use Google Play?

Aren't there Android users who don't have Google Play Services installed?
(In reply to Mike Kaply [:mkaply] from comment #5)

> Does the Android open source project use Google Play?

No.

> Aren't there Android users who don't have Google Play Services installed?

Yes, and there are Android users who have Play installed that don't want to use it (cf F-Droid).

Add to the mix that we might want to deliver updates to future AOSP partners (because we never want to rely on third parties to deliver timely updates), and I think eliminating the updater entirely for Android builds isn't likely to happen.

I think Joe's comment in Bug 1357362 Comment 7 suggests that he's reached the same conclusion:

> Aurora indeed can be updated either via Play Store or thru updater.
> Then this changes my thought. We could likely do the same.


The only remaining work would be to:

1. Ensure the Play/Updater detection works correctly, and updates are delivered as expected.
2. Decide whether to continue building and updating org.mozilla.fennec, perhaps distinguishing between Nightly for non-Play builds and Aurora for Play builds, or force those users to switch apps (which suggests a communication plan is needed).
To me, to be able to move fast without causing too much confusion (or needing work), my plans were the following:
* keep the current fennec nightly as it to limit the work here
* migrate the current aurora population to the nightly app (with the trick of reusing the apk name)
* run testsuite for both
* upload both on the ftp

The advantage of all this is that it is "easy" and quick. 
I expect that people who have been running nightly are tech-savvy, will hear about the GP app and switch if interested.

I believe we should also keep the current update mechanism and the current nightly. As some people wants to use fennec without Google play.

(which seems to be exactly what Richard said)
Flags: needinfo?(sledru)
Based on all the latest comments, it looks like we will make 2 of the same nightly builds but one being (org.mozilla.fennec_aurora) and the other being (org.mozilla.fennec) 

(org.mozilla.fennec_aurora) will update from Google Play AND our updater (same as how Aurora currently works)
(org.mozilla.fennec) will only update from our updater 

Agree this is likely the least effort and I think we can move forward as above but Richard's 2nd point on the remaining work is still valid that should be discussed. Technically, users can have 2 nightly that are exactly the same on their device (without an easy way to distinguish between the two, other than the 2 builds get updated differently). Given that users on (org.mozilla.fennec) are very limited, is it worth the effort to continue making dedicated builds when we can easily migrate these users to (org.mozilla.fennec_aurora)? Given the potential user confusion and the continuous effort in making an extra build, I recommend that we migrate the (org.mozilla.fennec) to (org.mozilla.fennec_aurora) at some time later
(In reply to Joe Cheng [:jcheng] (please needinfo) from comment #8)
> Agree this is likely the least effort and I think we can move forward as
> above but Richard's 2nd point on the remaining work is still valid that
> should be discussed. Technically, users can have 2 nightly that are exactly
> the same on their device (without an easy way to distinguish between the
> two, other than the 2 builds get updated differently). 
Yes, this will be ugly but I think/hope this will be a temporary solution.

> Given that users on (org.mozilla.fennec) are very limited, is it worth the effort to continue
> making dedicated builds when we can easily migrate these users to
> (org.mozilla.fennec_aurora)? 
Are you sure about the easily ?
I don't think we can do that automatically. This has to be done by the user, right?

> Given the potential user confusion and the
> continuous effort in making an extra build, I recommend that we migrate the
> (org.mozilla.fennec) to (org.mozilla.fennec_aurora) at some time later
Yes, I agree. 
But as we want to move fast, this should not block anything.
(In reply to Sylvestre Ledru [:sylvestre] from comment #9)
> > Given that users on (org.mozilla.fennec) are very limited, is it worth the effort to continue
> > making dedicated builds when we can easily migrate these users to
> > (org.mozilla.fennec_aurora)? 
> Are you sure about the easily ?
> I don't think we can do that automatically. This has to be done by the user,
> right?

correct. user action is needed but easy as in, we can notify the users in app to make the migration experience better
 
> > Given the potential user confusion and the
> > continuous effort in making an extra build, I recommend that we migrate the
> > (org.mozilla.fennec) to (org.mozilla.fennec_aurora) at some time later
> Yes, I agree. 
> But as we want to move fast, this should not block anything.

Yes agree
> > > Given the potential user confusion and the
> > > continuous effort in making an extra build, I recommend that we migrate the
> > > (org.mozilla.fennec) to (org.mozilla.fennec_aurora) at some time later
> > Yes, I agree. 
> > But as we want to move fast, this should not block anything.
> 
> Yes agree

If I understand correctly, Bug 1357358 can then be pending as we'll let the current Nightly (org.mozilla.fennec) stay what it is.
So no SUMO page is needed for that.
On the other end for org.mozilla.fennec_aurora, we'll still need Bug 1357360 though it is likely a SUMO page as well.
Can we confirm this here?
(In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #11)
> > > > Given the potential user confusion and the
> > > > continuous effort in making an extra build, I recommend that we migrate the
> > > > (org.mozilla.fennec) to (org.mozilla.fennec_aurora) at some time later
> > > Yes, I agree. 
> > > But as we want to move fast, this should not block anything.
> > 
> > Yes agree
> 
> If I understand correctly, Bug 1357358 can then be pending as we'll let the
> current Nightly (org.mozilla.fennec) stay what it is.
> So no SUMO page is needed for that.
> On the other end for org.mozilla.fennec_aurora, we'll still need Bug 1357360
> though it is likely a SUMO page as well.
> Can we confirm this here?

Per my conversation with Joe during Fennec funnel meeting, this is confirmed. 
I'm setting Bug 1357358 to won't fix then.
(In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #12)
> 
> Per my conversation with Joe during Fennec funnel meeting, this is
> confirmed. 
> I'm setting Bug 1357358 to won't fix then.

yes, we can deal with this at a later time
Depends on: 1357808
Depends on: 1363041
Just in case anyone else is confused after reading this bugchain: in the short term, we will be building two different builds that ship off of mozilla-central: one with the aurora id, and one with the nightly id. The aurora id one will become the primary build (because we already have more users on that id). At some point in the future, we'll kill the nightly id one.
Depends on: 1367912
Depends on: 1372215
Depends on: 1372623
We completed the dawn project, let's close this bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.