Cannot reinstall Lightning after removing/uninstalling (Lightning disappears)

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
6 months ago
6 months ago

People

(Reporter: Harvey Wamboldt, Unassigned)

Tracking

(Blocks: 1 bug)

Lightning 5.4

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 Safari/537.36

Steps to reproduce:

(1) Windows 7 Professional with all patches; Thunderbird 52.x 32-bit.
(2) Uninstalled all plugins and addons from a user profile using the Thunderbird GUI (pre version 52). (Regular user, no admin rights.) This removed Lightning.
(3) I then discovered that there was no way to re-install Lightning.
(4) Copied extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103} from another profile and fixed permissions. This restored Lightning; (I think).


Actual results:

Removing Lightning via the GUI is possible. Restoring Lightning through the GUI is not.


Expected results:

Thunderbird should have noticed that the Lightning extensions directory was missing and then allowed it to be restored. As a workaround, the manual procedure to restore Lightning should be documented and findable via Google/Bing etc.
(Reporter)

Updated

6 months ago
Summary: Cannot reinstall lightning after removing/uninstalling (Lightning disappears) → Cannot reinstall Lightning after removing/uninstalling (Lightning disappears)

Updated

6 months ago
Blocks: 1215828

Updated

6 months ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 52 Branch → Lightning 5.4

Comment 1

6 months ago
You can install Lightning from Menu Add-ons > Get Add-ons because Lightning 5.4 is finally released on addons.mozilla.org too: https://addons.mozilla.org/thunderbird/addon/lightning/versions/5.4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.