[RTL] broken UI layout after last update

VERIFIED FIXED in Firefox 53

Status

()

defect
VERIFIED FIXED
2 years ago
11 months ago

People

(Reporter: tomer, Assigned: maliu)

Tracking

(Blocks 1 bug, {regression})

53 Branch
Firefox 55
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec53+, firefox-esr52 unaffected, firefox53+ verified, firefox54+ fixed, firefox55+ fixed)

Details

()

Attachments

(2 attachments)

Reporter

Description

2 years ago
Please note that I can't reproduce this on my devices, I am just passing user feedback. 

A user provided feedback from our community page on Facebook about regression since last update (Fennec 53):

The URL bar layout is misaligned once he click on it. See attached screenshot.


Device: OnePlus 3T, Android 7.1.1, official stock ROM, Hebrew UI.
Browser: Firefox 53 (Release channel), switching languages between Hebrew and English has no effect.

Bug is visible only when Android system UI is set the Hebrew. Bug does not reproduce on English UI. This bug is a regression since previous version, as this is the first with RTL UI enabled.
Reporter

Comment 1

2 years ago
Posted image Screenshot
tracking-fennec: --- → ?
Comment hidden (mozreview-request)
[Tracking Requested - why for this release]:
This is a regression that impacts RTL users.
53 is the release we claim the RTL support so I'm nominating this fix to be uplifted.
tracking-fennec: ? → 53+
Attachment #8861300 - Flags: review?(s.kaspari)
Leaving this for ahunt to review.
Assignee: nobody → max
Status: NEW → ASSIGNED
It's misaligned but maybe still usable. 
Please request uplift to mozilla-release once the patch land on m-c and we can verify the fix. 
I'm not sure this will make the 53.0.2 dot release, which I'm hoping to build today.

Comment 6

2 years ago
mozreview-review
Comment on attachment 8861300 [details]
Bug 1358089 - [RTL] Separate xml drawable into v17 folder,

https://reviewboard.mozilla.org/r/133260/#review136586
Attachment #8861300 - Flags: review?(ahunt) → review+

Comment 7

2 years ago
Pushed by max@mxli.us:
https://hg.mozilla.org/integration/autoland/rev/3f259b3ca035
[RTL] Separate xml drawable into v17 folder, r=ahunt
Assignee

Comment 8

2 years ago
Comment on attachment 8861300 [details]
Bug 1358089 - [RTL] Separate xml drawable into v17 folder,

Approval Request Comment
[Feature/Bug causing the regression]: RTL Bug 1350661
[User impact if declined]: Fennec UI in LTR(English) with system locale in RTL(Hebrew) will see abnormal UI when editing in UrlBar 
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: Set android system locale to RTL(Hebrew) and specify fennec locale to LTR(English), click on Urlbar to edit and observe.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: Manually verified on multiple Android version.
[String changes made/needed]: No
Attachment #8861300 - Flags: approval-mozilla-release?
Attachment #8861300 - Flags: approval-mozilla-beta?
Attachment #8861300 - Flags: approval-mozilla-aurora?

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3f259b3ca035
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Hi Ioana, 
could you help find someone to verify if this issue was fixed as expected on a latest Nightly build? Thanks!
Flags: qe-verify+
Flags: needinfo?(ioana.chiorean)
Hi Mihai,
Can you help verify this?
Flags: needinfo?(mihai.ninu)

Comment 12

2 years ago
According to the user that reported this in the first place on our community page on Facebook, the issue is now fixed on latest Nightly.
Comment on attachment 8861300 [details]
Bug 1358089 - [RTL] Separate xml drawable into v17 folder,

Fix an RTL regression. Beta54+. Should be in 54 beta 4.
Attachment #8861300 - Flags: approval-mozilla-beta?
Attachment #8861300 - Flags: approval-mozilla-beta+
Attachment #8861300 - Flags: approval-mozilla-aurora?
Attachment #8861300 - Flags: approval-mozilla-aurora-
Comment on attachment 8861300 [details]
Bug 1358089 - [RTL] Separate xml drawable into v17 folder,

Verified fix, let's uplift it to m-r for the 53.0.2 dot release.
Attachment #8861300 - Flags: approval-mozilla-release? → approval-mozilla-release+
Device: Nexus 6 (Android 7.0)
Build 53.0.2
Reporter

Updated

2 years ago
Duplicate of this bug: 1361498

Comment 19

2 years ago
As this was verified by Bogdan, will take out the NI
Flags: needinfo?(mihai.ninu)
Flags: needinfo?(ioana.chiorean)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.