Blocking autoplay for background tabs (bug 1308154) is breaking twitter videos

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
6 months ago
5 months ago

People

(Reporter: Caspy7, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
I've experienced this on Beta 53 an Aurora 54.

1) create a fresh profile (may not be explicitly necessary)
2) ensure media.block-autoplay-until-in-foreground is set to true
3) open a twitter video (such as https://twitter.com/HollyweedMemes/status/854499913543159808 ) in a background tab
4) wait a full minute (not sure exactly, but 20 seconds is not long enough)
5) select the tab

Expectation:
The video plays.

Reality:
The video area displays: The media could not be played.

I see this frequently when sending video tweets from my phone.
I can repro this bug on my Macbook Pro with the latest nightly(55.0a1). The symptom is like Bug 1348326.
Flags: needinfo?(alwu)
(Reporter)

Comment 2

6 months ago
Created attachment 8860261 [details]
Twitter Video cannot play.

We should get these higher visibility issues squished before releasing this feature.

Here's a screenshot in case it makes it more compelling for folks.
It looks like Twitter's bug, it can also be reproduced on Chrome(57.0.2987.133), Safari(9.1) in OSX.
Please also consider to contact with Twitter for reporting this issue.
Flags: needinfo?(alwu) → needinfo?(bwu)
That's super fast response! 
Sweet. I will report this bug to them.
Flags: needinfo?(bwu)
Hi drichards,
Can you help us check this bug? It seems a Twitter bug.
Flags: needinfo?(drichards)
(Reporter)

Comment 6

6 months ago
drichards, in case you are unfamiliar with advanced flags in Firefox, for step #2 of my instructions, type about:config in the URL bar and hit enter. Then you can search for and toggle prefs.

As mentioned above though, similar functionality is already enabled and testable on Chrome and Safari.

Comment 7

6 months ago
Confirmed that this is a Twitter bug and not specific to Firefox. No ETA yet on a fix, but we'll look into it.
Flags: needinfo?(drichards)
(Reporter)

Comment 8

5 months ago
I have tested the steps on a couple of Twitter videos in both Firefox and Chrome and the issue seems to have been resolved so closing this bug.

Feel free to reopen if you cannot reproduce or you have some objection.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.