[meta] Block autoplay media until the tab is visible at first time

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: alwu, Assigned: alwu)

Tracking

(Depends on: 1 bug, {meta})

Other Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 56+)

Details

(Assignee)

Description

3 years ago
This feature is to avoid user have unexpected autoplay media from the new tab which doesn't be visited before.

We would block such kind of media and it would be resumed automatically when that tab becomes visible at the first time or user press the audio icon on the tab.

Updated

3 years ago
Depends on: 1308399
(Assignee)

Updated

2 years ago
Depends on: 1314220
Depends on: 1318462
(Assignee)

Updated

2 years ago
Depends on: 1319771, 1319529, 1319526
(Assignee)

Updated

2 years ago
Depends on: 1320005
(Assignee)

Updated

2 years ago
Depends on: 1322505
(Assignee)

Updated

2 years ago
Depends on: 1328058
(Assignee)

Updated

2 years ago
Depends on: 1330232
(Assignee)

Updated

2 years ago
Depends on: 1330195
(Assignee)

Updated

2 years ago
Depends on: 1331317
(Assignee)

Updated

2 years ago
Depends on: 1336309
(Assignee)

Updated

2 years ago
Depends on: 1337232
(Assignee)

Updated

2 years ago
Depends on: 1343465
(Assignee)

Updated

2 years ago
Depends on: 1347758
(Assignee)

Updated

2 years ago
No longer depends on: 1349201
Added to Fx54 (Aurora) release notes.
relnote-firefox: --- → 54+
(Assignee)

Updated

2 years ago
Depends on: 1350947
(Assignee)

Updated

2 years ago
Depends on: 1352014
(Assignee)

Updated

2 years ago
Depends on: 1347791

Updated

2 years ago
Depends on: 1358211
See Also: → bug 1338259

Comment 2

2 years ago
What's the status of this feature?  This seems to be a super common request from users in various online feedback that I see, and from the list of the dependencies it looks like it's really close, but I'm not sure how much work is left to ship this...

Thanks!
(In reply to :Ehsan Akhgari (needinfo please, extremely long backlog) from comment #2)
> What's the status of this feature?  This seems to be a super common request
> from users in various online feedback that I see, and from the list of the
> dependencies it looks like it's really close, but I'm not sure how much work
> is left to ship this...
> 
> Thanks!

I was not aware of this feature until recently. chsiang dug into testing status and this feature failed QA signoff for 55, so without uplifts it looks like we are on track for 56. While I have some sympathy for how close this seems to be, uplifts into beta must meet a very high bar of urgency and I'm not seeing that here.

needinfo'ing ajones to get his perspective on the work remaining and testing needed to move forward.
Flags: needinfo?(ajones)

Comment 4

2 years ago
Thanks!  FTR I wasn't advocating for it to be forced into beta necessarily, mostly just curious about the current state.  If we can ship it in 56 that's still great.
Add more info. 
Originally this feature failed QA signoff for 55 due to bug 1350947. Per discussion with chsiang last Monday, my team tend not to fix that bug related to Flash since it is too risky and not worth investing resource to support/maintain Flash cases. The main reason to defer this feature to 56 is UX spec has not been finalized yet especially for bug 1347791. If bug 1347791 is not needed, this feature is ready to go. For now, the current status is UX spec is under review and finalization.
(Assignee)

Updated

2 years ago
Depends on: 1367356

Updated

2 years ago
Depends on: 1378105
Duplicate of this bug: 647429
Moved to Fx56 (Beta) release notes.
relnote-firefox: 54+ → 56+
Flags: needinfo?(ajones)
(Assignee)

Updated

2 years ago
Depends on: 1387917
Depends on: 1394455
Depends on: 1394118
Comment hidden (offtopic)
(Assignee)

Comment 9

a year ago
Feature has been shipped to release channel.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Comment 10

a year ago
This "feature" causes facebook notification tones to leak memory in the parent process when facebook is not the active tab.
(Assignee)

Updated

8 months ago
Depends on: 1478108
(Assignee)

Updated

8 months ago
Depends on: 1478860
(Assignee)

Updated

8 months ago
Depends on: 1478869
(Assignee)

Updated

8 months ago
No longer depends on: 1478860
(Assignee)

Updated

8 months ago
No longer depends on: 1478108
(Assignee)

Updated

8 months ago
Alias: block-autoplay-media
(Assignee)

Updated

8 months ago
No longer depends on: 1478869
Keywords: meta
You need to log in before you can comment on or make changes to this bug.