bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Drag-n-drop a card to a list/ab and the target is not highlighted

VERIFIED FIXED in mozilla1.4alpha

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: shliang)

Tracking

Trunk
mozilla1.4alpha
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2][ue3])

Attachments

(1 attachment)

25.14 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
Trunk build 2002-04-05: WinMe

Overview: Drag-n-drop a card to a list or another address book in the directory 
pane and the target is not highlighted. This leaves the user wondering if the 
dnd process was successful.

Steps to reproduce:
1. Select a card from the results pane (right pane)
2. Drag it to a different address book in the directory pane (or a list)

Actual Results: The target address book never appears highlighted. The pointer 
is present with a little square (the card is copied to the destination).

Expected Results: If the mouse is on an address book/list then I would also 
expect it to be highlighted (i.e. dark blue).
(Reporter)

Comment 1

17 years ago
Marking nsbeta1 since most users would expect the Drag-n-drop process to work 
similar to the 3pane window where messages are drag-n-dropped from the thread 
pane to the folder pane.

ryi: Since the mailing list dialog is modal there are 2 ways to create a list. 
Open the list and type/autocomplete in the list dialog or drag-n-drop the 
entries from the results pane to the directory pane. 
Keywords: nsbeta1

Comment 2

17 years ago
Discussed in Mail News bug mtg with Engineering QA and PjM.  Decided to minus
this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha

Updated

16 years ago
Blocks: 118769
(Reporter)

Comment 3

16 years ago
Marking nsbeta1. If the target address book is not highlighted during a d-n-d
they may assume that it did not work.
Keywords: nsbeta1- → nsbeta1
OS: Windows ME → All
Target Milestone: mozilla1.2alpha → ---

Updated

16 years ago
Whiteboard: [ue3]

Comment 4

16 years ago
Mail triage team: nsbeta1+/adt2
Assignee: racham → shliang
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [ue3] → [adt2][ue3]
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.4alpha
(Assignee)

Comment 5

16 years ago
Created attachment 115439 [details] [diff] [review]
patch 

convert dirTree to use xul tree builder, and fix dirTreeObserver so that dnd
feedback will work
(Assignee)

Updated

16 years ago
Attachment #115439 - Flags: review?(sspitzer)
what about showing mailing lists, local, ldap, and secure ldap icons in the dir
tree?  does that work with your patch? 

I'll review more tomorrow.
or is it the case that you can just make the switch to the tree builder, and the
old css just works?
(Assignee)

Comment 8

16 years ago
the icons are still there (i don't think the css should have to change)
Comment on attachment 115439 [details] [diff] [review]
patch 

r/sr=sspitzer

I also smoketested this patch, and it looked good.

thanks shuehan, nice work.
Attachment #115439 - Flags: superreview+
Attachment #115439 - Flags: review?(sspitzer)
Attachment #115439 - Flags: review+
(Assignee)

Updated

16 years ago
Blocks: 132362
(Assignee)

Updated

16 years ago
Blocks: 130310
after you can you spin up a new bug about how sort order / direction is now
global (instead of per addressbook / mailing list?)

i don't think we should fix it right away, but we should log it, and then triage
it.  (I expect nsbeta1-)
Status: NEW → ASSIGNED
(Assignee)

Comment 11

16 years ago
marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

16 years ago
Trunk build 2003-03-03: WinXP, Linux RH 8
Verified Fixed, and I also still see the mailing lists, local, ldap, and secure
ldap icons.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.