Emails not being retrieved from Charter server since update to 52.0.1

RESOLVED DUPLICATE of bug 1231592

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1231592
2 months ago
2 months ago

People

(Reporter: Kathy, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 Safari/537.36

Steps to reproduce:

Thunderbird updated to version 52.0.1


Actual results:

Thunderbird only retrieves emails from my server (Charter) at the beginning or start.  I have to end Thunderbird and restart in order to retrieve new emails.


Expected results:

I should be able to download new emails while Thunderbird is open by clicking on 'get messages'.  The only time Thunderbird downloads emails is when I first start the program. If additional emails arrive at my server, I shouldn't have to restart Thunderbird in order to download the additional emails.
Summary: Emails not being retrieved from server since update → Emails not being retrieved from Charter server since update to 52.0.1

Comment 1

2 months ago
Yes, this is a known problem with Charter servers. We fixed this in bug 1231592. That solution is not contained in TB 52 yet.

The workaround is to set these preferences:
mail.server.default.use_idle = false
mail.server.serverX.max_cached_connections = 1
mail.imap.expunge_after_delete = true

See bug 1231592 comment #12.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231592

Comment 2

2 months ago
Actually, the above preferences only fix the the original bug subject:

"With Charter ISP's IMAP server, deleted or marked as spam emails won't restore to inbox and are lost"

The only workaround to not receiving new emails from charter imap automatically to also go to "Junk Settings" and select "Automatically delete junk mail older than XX days". 

It is described here: https://bugzilla.mozilla.org/show_bug.cgi?id=1231592#c47

Note: I think I may has misspoke in item d) in that comment since I don't think clicking on "get new mail" will bring in new email. However, probably selecting another folder and then going back to Inbox will bring in new email (since it forces a re-select when you have only 1 connection). In any case, the polling timer can be disabled or just remain at default of 10m since it won't work with charter.

Comment 3

2 months ago
Actually, the above preferences only fix the the original bug subject:

"With Charter ISP's IMAP server, deleted or marked as spam emails won't restore to inbox and are lost"

The workaround to not receiving new emails from charter imap automatically is to also go to "Junk Settings" and select "Automatically delete junk mail older than XX days". 

It is described here: https://bugzilla.mozilla.org/show_bug.cgi?id=1231592#c47 (see listed items a-d).

Note: I think I may has misspoke in item d) in that comment since I don't think clicking on "get new mail" will bring in new email. However, probably selecting another folder and then going back to Inbox will bring in new email (since it forces a re-select when you have only 1 connection). In any case, the polling timer can be disabled or just remain at default of 10m since it won't work with charter.

Also, to clarify the items listed above:
mail.server.default.use_idle = false* (uncheck "Allow immediate server notifications..."  in Server Settings
mail.server.serverX.max_cached_connections=1 "Maximum number of server connection to cache" in Server Settings/Advanced
mail.imap.expunge_after_delete = true (this is set in Config Editor under Preferences | Advanced)

* Doesn't really matter how this is set since charter doesn't support "idle".
You need to log in before you can comment on or make changes to this bug.