Account Wizard: Creates duplicate entries in Acct Manager

VERIFIED FIXED in M11

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 1999091009M11: Win32/NT4

Overview: Start the Account Setup Wizard and add a new mail account. In the last
dialog select the Finish button and nothing appears to happen. Launch the
Account Manager, select the new account and the settings are not saved, all the
entries are blank.

Steps to reproduce:
1. Launch Mail using one account (qatest20)
2. Launch the Account Setup Wizard to add another account (i.e. qatest22). In
this build select Edit/New Account Wizard.
3. Progress through the dialogs by selecting the Next button.
4. On the last dialog select the Finish button and nothing appears to happen.
5. Select the Next button a couple of times and again nothing appears to happen.
6. Close the dialog by selecting the close box, "x".
7. Select Edit/Account Setup to verify that the new account is present.

Actual Results:
1. The new account displays mutliple times. It appears that everytime I select
the Next button or the Finish button in the last dialog of the Account Wizard,
it creates another instance in the Account Manager window.
2. Select the new account and no information is saved in the account panel.
3. Select the first account (qatest20) and it displays the correct account
information.
4. Select the new account (qatest22) again and it displays the first account
information. I noticed that the panels don't actually appear to repaint. If
I double click onto the new account I see two panels underneath for Server
and Copies. If I select either panel the information in the right does not
change. It continues to show the account panel for qatest20.
5. After restarting mail the folder pane shows qatest32 but its special folders
are not present (i.e. Trash, Sent).

Expected Results: The Account Wizards last dialog should have:
- a Finish button that closes the dialog.
- If I check the Account Manager then one new account should be displayed.
- If I select the new account and its subpanels then the information in the
right should reflect the account panel selected.
- The account should also appear in the folder pane.
- After restarting the application all this information should still be present.

Additional Information:
I haven't tried this yet on Linux or the Mac.
(Reporter)

Updated

18 years ago
Assignee: phil → alecf
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

18 years ago
Assigning to alecf, QA Contact nbaca, Cc: lchiang.

One additional Note: If the Account Manager shows multiple instances of a new
account (qatest22) then these accounts are not displayed in the folder pane. I
tried resizing and minimizing the window with no effect. After restarting Mail
then the folder displayed multiple instances of the new account in the folder
pane. For instance it showed four qatest22 accounts.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

18 years ago
as it turns out, part of this problem is due to the broken combo box. In the
wizard, it creates new accounts based on the server type, but since the GFX
combo box is broken so that nothing is selected by default, it tries to create a
server with an empty type, "", which fails. This makes the window fail to close,
and so ninoshka is able to press next multiple times.

I have a workaround for this that should at least prevent the servers from being
created multiple times.
(Assignee)

Updated

18 years ago
Target Milestone: M11
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

18 years ago
ok, this won't happen again. Checked in my workaround.
I wish I knew where the other bug was.
(Reporter)

Updated

18 years ago
Depends on: 14146
(Reporter)

Comment 4

18 years ago
Fixed using Build 1999092309M11: Win32/NT4, Linux/Redhat 5.0
Can't verify on Mac until zombie bug# 14146 is fixed.
(Reporter)

Updated

18 years ago
Depends on: 17696
(Reporter)

Comment 5

18 years ago
Unable to verify this bug on the Mac until 17696 is fixed.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
Build 1999110208M11: Mac 8.5.1
Verified Fixed. I created a new account and duplicate entries did not appear,
only one as expected.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.