Closed Bug 1359886 Opened 3 years ago Closed 3 years ago

Regression April 12th in accelerated Flash async plugin drawing use

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox55 --- affected

People

(Reporter: jimm, Assigned: jimm)

References

()

Details

https://wiki.mozilla.org/Plugins/Async_Drawing#Telemetry_Links

We have a regression in accelerated rendering use within the async drawing populations of sites. Originally we were running around 70%/30% accelerated/un-accelerated. Around April 12th this reversed to 25%/70%. Thi s is significant enough that we'll have to hold rollout until it's addressed.

The regression showed up in both nightly and aurora. Gfx says nothing major landed in both repos on that date. Plugin code didn't have any landings with uplifts either. 

In general this looks like a regression in Flash's April 11th point release.
Assignee: nobody → jmathies
Drawing modes: 
NPDrawingModelAsyncBitmapSurface - un-accelerated
NPDrawingModelAsyncWindowsDXGISurface - accelerated
Summary: Regression April 12th in accelerated async plugin drawing use → Regression April 12th in accelerated Flash async plugin drawing use
Depends on: 1363611
Fixed May 8th, likely through a Flash update.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.