Closed Bug 136054 Opened 19 years ago Closed 12 years ago

DL manager doesn't observe history expire pref

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 251337

People

(Reporter: BenB, Unassigned)

References

Details

(Keywords: perf, privacy)

Without knowing that the download manager exists at all, I just found that it
stores the files I downloaded. And it does so bejond the time the normal browser
history stores the urls.

Browser history pref: expire after 9 days
Download manager shows files downloaded 2002-03-26
Today is 2002-04-07.

Not sure when they will eventually expire, if ever, but this is a privacy violation.
Keywords: privacy
cross-bug note:  bug 136054, bug 132755, and bug 141794 all specify different
ways to expire entries from the download history.  To avoid duplication of
effort, work on any one bug should be coordinated (if not combined) with work on
the others.
Blocks: 75364
QA Contact: sairuh → petersen
Keywords: perf
Product: Browser → Seamonkey
Assignee: bross2 → download-manager
QA Contact: chrispetersen
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Move to toolkit download manager made this a dupe of bug 251337.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 251337
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.