[META] Download Manager Features

VERIFIED INVALID

Status

Core Graveyard
Tracking
--
enhancement
VERIFIED INVALID
17 years ago
2 years ago

People

(Reporter: Peter Lairo, Assigned: Peter Lairo)

Tracking

(Depends on: 4 bugs, {meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
This bug is meant to be a gathering place (Meta Bug) for all *Download Manager*
related features. It should be used to track and coordinate all bugs that deal
with file downloading issues.

Here is a list of bugs I have identified so far:

- bug 25995: [RFE] Download manager (multiple downloads per window)
- bug 18004: [RFE]resuming stopped downloads
- bug 58744: 3rd party download managers not supported
- bug 75359: Show Downloads in a Sidebar tab (filename, progress, pause/cancel, etc)
- bug 75360: Allow "Segmented Downloading" for large files (mutiple download
segments per file)
- bug 75362: Preferences (prefs) UI for all "Download Manager" Features

The above bugs shoud be marked "bug blocks" to this bug by those that have the
authority to do so (not me).

Let's get this cool feature rolling ;)
(Assignee)

Updated

17 years ago
Depends on: 18004, 25995, 58744, 75359, 75360, 75362
Keywords: helpwanted, meta, mozilla1.0, nsCatFood
(Assignee)

Updated

17 years ago
No longer depends on: 25995
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
Peter, that's the second duplicate of bug 25995 you've filed. Stop it, it's 
annoying.

*** This bug has been marked as a duplicate of 25995 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

17 years ago
This bug isn't a dupe of bug 25995. That bug is *only* for "Multiple Downloads
per Window" (see summary and 90% of comments).

This bug is to track *ALL* Download Manager features that are floating around -
Am I overlooking something? Otherwise the other bug needs to be marked as a meta
bug and list all dependencies.

Comment 3

17 years ago
Peter, who is it that you want tracking these bugs.  You've assigned this bug to
me  and I have no interest in tracking those bugs.  If _you_ are interested in
tracking those bugs then feel free to assign this bug to yourself or be
prepaired for me to resolve it as verify it as a Duplicate or reopen and Resolve
it as Invalid.
(Assignee)

Comment 4

17 years ago
I only created this bug. The "assigned to" was automatically generated. I would
be willing to track this bug, but please note that i am just a regular user and
not part of the "inner circle". If you e-mail me with instructions on what
"tracking" involves, i'll give it a shot :)

Comment 5

17 years ago
reopening, assigning to PLairo@cs.com. 

Peter.  If these are bugs that you would like to track as a group then great. 
If others find this a useful group to track then even better.  
Status: RESOLVED → REOPENED
Component: Browser-General → Tracking
Resolution: DUPLICATE → ---

Comment 6

17 years ago
reassign.
Assignee: asa → PLairo
Status: REOPENED → NEW
(Assignee)

Comment 7

17 years ago
adding depends on bug 25995 - [RFE] Download manager (multiple downloads per window)
Depends on: 25995

Comment 8

17 years ago
*** Bug 79776 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

17 years ago
*** Bug 64759 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Depends on: 78193
(Assignee)

Updated

17 years ago
Depends on: 67216
(Assignee)

Comment 10

17 years ago
adding depends on for bug 35046 - [RFE] Show download progress (%) in title when
minimized
Depends on: 35046
(Assignee)

Updated

17 years ago
Depends on: 83261
(Assignee)

Comment 11

17 years ago
added depends on bug 83261 - UI for Pause/Resume in Download Progress Window

Comment 12

17 years ago
No point in nominating tracking bugs for anything, since tracking bugs can't be
fixed. Removing silly keywords.
Keywords: helpwanted, mozilla1.0, nsCatFood
(Assignee)

Updated

17 years ago
Depends on: 95210
(Assignee)

Updated

17 years ago
Depends on: 95211

Comment 13

17 years ago
*** Bug 102836 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Depends on: 102477
bill/ben, found this tracking bug which might help you with organizing download
mgr bugs...
QA Contact: doronr → sairuh
(Assignee)

Updated

16 years ago
Depends on: 115574
(Assignee)

Updated

16 years ago
Depends on: 55690
No longer depends on: 25995, 83261, 95210, 115574
(Assignee)

Updated

16 years ago
Depends on: 115574
(Assignee)

Comment 15

16 years ago
Added: "depends on:" bug 7840 - [RFE] Ability to specify default directory for
downloads

That bug is over *THREE YEARS OLD* and is long overdue!!! Please, someone go
there and (gently) kick some booty ;)
Depends on: 7840
(Assignee)

Comment 16

16 years ago
Added: "depends on:" bug 103487 - use of default anti-virus scanner when
downloading email and executables
Depends on: 103487
(Assignee)

Updated

16 years ago
Depends on: 115981
(Assignee)

Updated

16 years ago
Depends on: 69938
(Assignee)

Updated

16 years ago
Depends on: 22796

Updated

16 years ago
No longer depends on: 22796

Comment 17

16 years ago
The download manager got its own component. There should be no more need for a
tracking bug.

http://bugzilla.mozilla.org/buglist.cgi?product=Browser&component=Download+Manager

Comment 18

16 years ago
adding self to cc list

Updated

16 years ago
Depends on: 144325
Here are some more suggestions for DownloadManager
- make resume work (it did not work with Moz1.0 RC2)
- allow user to configure DM via Prefs
- make DM "consume" those single "download windows": there's no sence in seeing
download-infos two times
  I think there should be 3 options:
  + don't use DM: so for every download one of those small MsgBoxes will pop-up
(old-fashioned)
  + use DM normal: instead of the DownloadMsgBox the DM will popup displaying
all infos
  + use DM hidden: nothing is popped up, DM handles downloads silently
- Properties should be something different than the DownloadMsgBox, which is
even not available one the download is finished
- make the UI more "beautiful", not overloaded of graphics but maybe icons for
stop, resume etc.
- make DM report correct download status! I downloaded Moz 1.0 RC2 and the
connection broke (I did not yet realize). The DownloadMsgBox  and DM both said
"download completed", but it was stopped/stalled and not complete. So the
installer crashed and I just thought it must have been a tranfer-error. Right
~500kB were missing.
- enable queueing. I think this is really useful when you want to download more
than one file.
- Bandwidth-Priority-Control, Browser vs. downloads etc.

Comment 20

16 years ago
Bug 136054, bug 132755, and bug 141794 all specify different ways to expire
entries from the download history.
Depends on: 132755, 136054, 141794

Comment 21

16 years ago
Nominating bug 148650

Updated

16 years ago
No longer depends on: 141794

Comment 22

16 years ago
*** This bug has been marked as a duplicate of component "Download Manager" ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → INVALID
:) verified.
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer depends on: 115981
(Assignee)

Updated

14 years ago
Depends on: 24625
No longer depends on: 115574
(Assignee)

Updated

14 years ago
Depends on: 40106

Updated

11 years ago
No longer depends on: 103487
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.