Closed Bug 1360699 Opened 4 years ago Closed 4 years ago

Fennec Custom Tab doesn't close after pressing back or close buttons.

Categories

(Firefox for Android Graveyard :: General, defect)

55 Branch
All
Android
defect
Not set
normal

Tracking

(firefox55 fixed)

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: smartfon.reddit, Assigned: JanH)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170428030259

Steps to reproduce:

Updated to 4/28/2017 Nightly. Tap on a link on any app to open a page with Custom Tabs. Press the phone's "back" or Custom Tab's "close" button to close and return to original app.


Actual results:

It minimizes the Custom Tab. Opening the original app opens the Custom Tab, since it was never closed. Pressing X to close Custom Tab just minimizes it. The only way to close Custom Tabs and make the original app usable again is by clearing the original app  from memory.


Expected results:

Pressing back or close button should return to original app.
Assignee: nobody → jh+bugzilla
Blocks: 1352997
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
So originally I must have gotten the impression that calling finish() made it more likely that Gecko would be unloaded as soon as we've backed out of the activity, which is best avoided if we don't want users to have to wait for Gecko to start up each time they're exiting and then opening the next custom tab.
On re-testing I couldn't reproduce this, though (maybe the MediaControlService is keeping us alive as an unintentional but beneficial side effect - although I don't think anything has changed there recently since I started working on this).

The reason why I didn't notice this is that I'm using "ActivityForceNewTask" on my phone, so custom tabs would launch in a task separate from their calling activity, in which case MoveTaskToBack naturally doesn't have any ill side effects.
Comment on attachment 8863127 [details]
Bug 1360699 - Finish CustomTabsActivities when leaving.

https://reviewboard.mozilla.org/r/134954/#review138240
Attachment #8863127 - Flags: review?(walkingice0204) → review+
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/daaac7877e43
Finish CustomTabsActivities when leaving. r=walkingice
Duplicate of this bug: 1361367
https://hg.mozilla.org/mozilla-central/rev/daaac7877e43
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Is this new problem related to this bug, or should I open a new one? It started few days ago.

Custom Tab closes and opens Firefox's Nightly Home page instead of navigating to original app, after pressing Android back button.

1. Open Nightly. Enable Custom Tabs. Swipe and close all items from tab manager, including Firefox Nightly tab. You'll have a new active instance of Firefox Nightly.

2. Swipe and close Nightly from Android recents memory.

3. Open a 3rd party app and tap on a website link. Custom Tabs opens the site.

4. Press the Android back button to go back to 3rd party app. It closes the Custom Tab and opens Android Nightly's Nightly Home tab (where bookmarks and history are).
Separate issue.
See Also: → 1362846
Verified as fixed on all branches. Devices: Nexus 6(Android 6.0.1), HTC 10(Android 8.1.0) and Samsung Galaxy S8(Android 7.0)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.