Closed Bug 1360812 Opened 3 years ago Closed 2 years ago

Font display issue with Fulah (missing glyphs on bold text)

Categories

(www.mozilla.org :: Pages & Content, defect)

Production
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: flod, Assigned: kohei)

References

()

Details

Attachments

(3 files)

A similar problem was fixed in bug 776967, issue was reported on dev-l10n mailing list.

I definitely see the problem on the home page and on the Technology page, not sure if it's limited to the bold weight.
https://bugzilla.mozilla.org/show_bug.cgi?id=776967
Yeah, the bold and bold italic subsets are missing. The problem is the M+ font doesn't have italic variants, so I need another font to create subsets. Will try Noto Sans first. https://www.google.com/get/noto/

Actually, Noto Sans covers more languages than Open Sans, so we should probably use it site wide.
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Looks like someone already mentioned Noto Sans in the thread.
https://groups.google.com/d/topic/mozilla.dev.l10n/CGTHsm7Ha5o/discussion
Ibrahima: what's your opinion about Noto Sans? If it's fine, I can quickly create the bold and bold italic subsets to solve the issue.
Flags: needinfo?(ibrahima.sarr)
... or simply use Noto Sans for all Fulah glyphs, instead of Open Sans + subsets.
Hi
Noto Sans looks good although you can only tell for sure on a live site. Cheers and thanks
Flags: needinfo?(ibrahima.sarr)
Yeah, I've just set up a demo server :) Have a look: https://bedrock-demo-fulah-fonts.us-west.moz.works/ff/
Flags: needinfo?(ibrahima.sarr)
I've added the semibold weight as well which is used for the newsletter form title on https://bedrock-demo-fulah-fonts.us-west.moz.works/ff/about/
All look good. Thanks s lot.
Flags: needinfo?(ibrahima.sarr)
Attached file pull request
Thanks! I've just sent a pull request to merge the change.
Blocks: 937413
Locale: ff / Fulah
Thanks a lot. Looking forward to deployment on live site. 
Cheers
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/94369509380ac0e93c3b7cf51ab6ace7ee5a0fa9
Fix Bug 1360812 - Font display issue with Fulah (missing glyphs on bold text)

https://github.com/mozilla/bedrock/commit/838a2c3ba2390a56bb75ea18e44441cba1d4fdf5
Merge pull request #4813 from mozilla/demo__fulah-fonts

Fix Bug 1360812 - Font display issue with Fulah (missing glyphs on bold text)
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.