Thunderbird 52.0 sometimes truncates downloaded attachments

RESOLVED DUPLICATE of bug 1355350

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1355350
7 months ago
7 months ago

People

(Reporter: Tilman Schmidt, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

Open a mail in an IMAP folder with a big file attachment.
Either double-click on the attachment to open it, or right-click and select "download".


Actual results:

Downloaded attachment appears incomplete in the application used to open it, or file is truncated on local disk.
Repeating the attempt without restarting Thunderbird produces the same result.
After closing and restarting Thunderbird, the same attachment is in most cases opened or downloaded completely.


Expected results:

Attachment should reliably be downloaded completely.
(Reporter)

Comment 1

7 months ago
Additional information:

The problem occurs on Microsoft Windows 7 Professional when accessing IMAP accounts on a local Zarafa mailserver.
It appeared after upgrading from Thunderbird release 45.7 to release 52.0, persisted after upgrading to 52.0.1, and disappears after downgrading to 45.8.
The problem is not deterministic: The same attachment may download completely on one attempt and be truncated on another, either on the same machine or a different one.
Yes, that sadly happens when the folder is not synchronised for offline use. We've written it into the release notes:
https://www.mozilla.org/en-US/thunderbird/52.0.1/releasenotes/
https://www.mozilla.org/en-US/thunderbird/52.1.0/releasenotes/, 52.1.0 available now.

You can either try the workaround or use TB 54 beta. That hasn't been published yet, but you can get an unofficial version here:
https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-beta-win32/1493460706/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1355350
You need to log in before you can comment on or make changes to this bug.